Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1648040

[PATCH v6 net-next 02/17] net: qca_framing: use u16 for frame offset

From Stefan Wahren <stefan.wahren@i2se.com>
Newsgroups linux.kernel
Subject [PATCH v6 net-next 02/17] net: qca_framing: use u16 for frame offset
Date 2017-05-23 15:20 +0200
Message-ID <tKhTd-3GR-51@gated-at.bofh.it> (permalink)
References <tKhTb-3GR-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


It doesn't make sense to use a signed variable for offset here, so
fix it up.

Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
---
 drivers/net/ethernet/qualcomm/qca_framing.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/net/ethernet/qualcomm/qca_framing.h b/drivers/net/ethernet/qualcomm/qca_framing.h
index d5e795d..8b385e6 100644
--- a/drivers/net/ethernet/qualcomm/qca_framing.h
+++ b/drivers/net/ethernet/qualcomm/qca_framing.h
@@ -103,7 +103,7 @@ struct qcafrm_handle {
 	enum qcafrm_state state;
 
 	/* Offset in buffer (borrowed for length too) */
-	s16 offset;
+	u16 offset;
 
 	/* Frame length as kept by this module */
 	u16 len;
-- 
2.1.4

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v6 net-next 00/17] net: qualcomm: add QCA7000 UART driver Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 07/17] net: qca_spi: remove QCASPI_MTU Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 09/17] net: qca_spi: Clarify MODULE_DESCRIPTION Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 03/17] net: qca_7k: Use BIT macro Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 14/17] dt-bindings: qca7000: rename binding Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 10/17] net: qualcomm: rename qca_framing.c to qca_7k_common.c Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 04/17] net: qca_spi: Use SET_NETDEV_DEV() Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 12/17] net: qualcomm: make qca_7k_common a separate kernel module Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 06/17] net: qualcomm: Improve readability of length defines Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 05/17] net: qualcomm: use net_device_ops instead of direct call Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 15/17] dt-bindings: slave-device: add current-speed property Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 02/17] net: qca_framing: use u16 for frame offset Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
  [PATCH v6 net-next 01/17] net: qualcomm: remove unnecessary includes Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
    Re: [PATCH v6 net-next 01/17] net: qualcomm: remove unnecessary  includes David Miller <davem@davemloft.net> - 2017-05-24 21:50 +0200
      Re: [PATCH v6 net-next 01/17] net: qualcomm: remove unnecessary  includes Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-24 22:10 +0200
        Re: [PATCH v6 net-next 01/17] net: qualcomm: remove unnecessary  includes David Miller <davem@davemloft.net> - 2017-05-24 22:50 +0200

csiph-web