Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1648028
| From | Stefan Wahren <stefan.wahren@i2se.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v6 net-next 03/17] net: qca_7k: Use BIT macro |
| Date | 2017-05-23 15:20 +0200 |
| Message-ID | <tKhTc-3GR-23@gated-at.bofh.it> (permalink) |
| References | <tKhTb-3GR-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Use the BIT macro for the CONFIG and INT register values. Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com> --- drivers/net/ethernet/qualcomm/qca_7k.h | 14 +++++++------- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/net/ethernet/qualcomm/qca_7k.h b/drivers/net/ethernet/qualcomm/qca_7k.h index 1cad851..4047f0a 100644 --- a/drivers/net/ethernet/qualcomm/qca_7k.h +++ b/drivers/net/ethernet/qualcomm/qca_7k.h @@ -54,15 +54,15 @@ #define SPI_REG_ACTION_CTRL 0x1B00 /* SPI_CONFIG register definition; */ -#define QCASPI_SLAVE_RESET_BIT (1 << 6) +#define QCASPI_SLAVE_RESET_BIT BIT(6) /* INTR_CAUSE/ENABLE register definition. */ -#define SPI_INT_WRBUF_BELOW_WM (1 << 10) -#define SPI_INT_CPU_ON (1 << 6) -#define SPI_INT_ADDR_ERR (1 << 3) -#define SPI_INT_WRBUF_ERR (1 << 2) -#define SPI_INT_RDBUF_ERR (1 << 1) -#define SPI_INT_PKT_AVLBL (1 << 0) +#define SPI_INT_WRBUF_BELOW_WM BIT(10) +#define SPI_INT_CPU_ON BIT(6) +#define SPI_INT_ADDR_ERR BIT(3) +#define SPI_INT_WRBUF_ERR BIT(2) +#define SPI_INT_RDBUF_ERR BIT(1) +#define SPI_INT_PKT_AVLBL BIT(0) void qcaspi_spi_error(struct qcaspi *qca); int qcaspi_read_register(struct qcaspi *qca, u16 reg, u16 *result); -- 2.1.4
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v6 net-next 00/17] net: qualcomm: add QCA7000 UART driver Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 07/17] net: qca_spi: remove QCASPI_MTU Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 09/17] net: qca_spi: Clarify MODULE_DESCRIPTION Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 03/17] net: qca_7k: Use BIT macro Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 14/17] dt-bindings: qca7000: rename binding Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 10/17] net: qualcomm: rename qca_framing.c to qca_7k_common.c Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 04/17] net: qca_spi: Use SET_NETDEV_DEV() Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 12/17] net: qualcomm: make qca_7k_common a separate kernel module Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 06/17] net: qualcomm: Improve readability of length defines Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 05/17] net: qualcomm: use net_device_ops instead of direct call Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 15/17] dt-bindings: slave-device: add current-speed property Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 02/17] net: qca_framing: use u16 for frame offset Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
[PATCH v6 net-next 01/17] net: qualcomm: remove unnecessary includes Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-23 15:20 +0200
Re: [PATCH v6 net-next 01/17] net: qualcomm: remove unnecessary includes David Miller <davem@davemloft.net> - 2017-05-24 21:50 +0200
Re: [PATCH v6 net-next 01/17] net: qualcomm: remove unnecessary includes Stefan Wahren <stefan.wahren@i2se.com> - 2017-05-24 22:10 +0200
Re: [PATCH v6 net-next 01/17] net: qualcomm: remove unnecessary includes David Miller <davem@davemloft.net> - 2017-05-24 22:50 +0200
csiph-web