Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1647267
| Path | csiph.com!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | Andy Shevchenko <andriy.shevchenko@linux.intel.com> |
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 23/23] uuid: remove uuid_be |
| Date | Mon, 22 May 2017 21:00:02 +0200 |
| Message-ID | <tK0IF-R8-11@gated-at.bofh.it> (permalink) |
| References | <tIn6G-68Z-11@gated-at.bofh.it> <tIn6G-68Z-23@gated-at.bofh.it> <tIovM-7em-15@gated-at.bofh.it> <tIprP-7UI-5@gated-at.bofh.it> |
| X-Extloop1 | 1 |
| X-Ironport-Av | E=Sophos;i="5.38,378,1491289200"; d="scan'208";a="860074981" |
| Organization | Intel Finland Oy |
| Content-Type | text/plain; charset="UTF-8" |
| X-Mailer | Evolution 3.22.6-1 |
| MIME-Version | 1.0 |
| Content-Transfer-Encoding | 8bit |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 39 |
| X-Original-Cc | linux-fsdevel <linux-fsdevel@vger.kernel.org>, Shaohua Li <shli@kernel.org>, Dan Williams <dan.j.williams@intel.com>, David Howells <dhowells@redhat.com>, Steven Whitehouse <swhiteho@redhat.com>, Mimi Zohar <zohar@linux.vnet.ibm.com>, linux-xfs <linux-xfs@vger.kernel.org>, linux-raid@vger.kernel.org, linux-nvdimm@lists.01.org, linux-kernel <linux-kernel@vger.kernel.org>, Hugh Dickins <hughd@google.com> |
| X-Original-Date | Mon, 22 May 2017 21:59:25 +0300 |
| X-Original-Message-ID | <1495479565.6967.72.camel@linux.intel.com> |
| X-Original-References | <20170518062705.25902-1-hch@lst.de> <20170518062705.25902-24-hch@lst.de> <CAOQ4uxj+TH5vS5HoEFPJXUpneBqr+YwbVES0bsHzw9qmS8HzKg@mail.gmail.com> <20170518085629.GA6149@lst.de> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1647267 |
Show key headers only | View raw
On Thu, 2017-05-18 at 10:56 +0200, Christoph Hellwig wrote: > On Thu, May 18, 2017 at 10:57:24AM +0300, Amir Goldstein wrote: > > I reviewed the entire series. You may add > > Reviewed-by: Amir Goldstein <amir73il@gmail.com> > > > > to any of the patches as you see fit. > > Thanks, done! Similar from my side, FWIW: Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com> > > > Now let's talk about how this is going to be merged. > > Do you intend to send Linus a pull request? > > Yes, that might be the best idea. I'm also contemplating listing > me plus anyone volunteering (you?, Andy) as maintaines for the uuid > code. I would agree to be a designated reviewer for now (too many stuff to follow as a (co-)maintainer). > > The reason I am asking is because this last removal patch should > > probably > > be applied near the end of the merge window (?). > > Because maintainers cannot apply patches with code that uses the new > > uuid_t to linux-next branches and we don't want linux-next build to > > fail > > with new code that uses uuid_be... > > Yeah, we can probably defer that one for now. I would also like to append some of patches from my side, though they are WIP. -- Andy Shevchenko <andriy.shevchenko@linux.intel.com> Intel Finland Oy
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
cleanup UUID types V3 Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 21/23] nvme: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 20/23] sysctl: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 15/23] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
Re: [PATCH 15/23] block: remove blk_part_pack_uuid Mimi Zohar <zohar@linux.vnet.ibm.com> - 2017-05-19 01:20 +0200
[PATCH 23/23] uuid: remove uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
Re: [PATCH 23/23] uuid: remove uuid_be Amir Goldstein <amir73il@gmail.com> - 2017-05-18 10:00 +0200
Re: [PATCH 23/23] uuid: remove uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-18 11:00 +0200
Re: [PATCH 23/23] uuid: remove uuid_be Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-22 21:00 +0200
[PATCH 22/23] scsi_debug: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 01/23] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
Re: [PATCH 01/23] xfs: use uuid_copy() helper to abstract uuid_t Brian Foster <bfoster@redhat.com> - 2017-05-18 15:30 +0200
Re: [PATCH 01/23] xfs: use uuid_copy() helper to abstract uuid_t "Darrick J. Wong" <darrick.wong@oracle.com> - 2017-05-19 01:40 +0200
[PATCH 05/23] uuid: don't export guid_index and uuid_index Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 09/23] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 14/23] xfs: use the common helper uuid_is_null() Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
Re: [PATCH 14/23] xfs: use the common helper uuid_is_null() Brian Foster <bfoster@redhat.com> - 2017-05-18 15:30 +0200
[PATCH 19/23] partitions/ldm: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
[PATCH 08/23] uuid: hoist uuid_is_null() helper from libnvdimm Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
[PATCH 11/23] uuid: remove struct uuid_v1 Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
[PATCH 02/23] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 02/23] xfs: use uuid_be to implement the uuid_t type Brian Foster <bfoster@redhat.com> - 2017-05-18 15:30 +0200
Re: [PATCH 02/23] xfs: use uuid_be to implement the uuid_t type "Darrick J. Wong" <darrick.wong@oracle.com> - 2017-05-19 01:40 +0200
[PATCH 12/23] xfs: remove uuid_getnodeuniq and xfs_uu_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 12/23] xfs: remove uuid_getnodeuniq and xfs_uu_t Brian Foster <bfoster@redhat.com> - 2017-05-18 15:30 +0200
Re: [PATCH 12/23] xfs: remove uuid_getnodeuniq and xfs_uu_t "Darrick J. Wong" <darrick.wong@oracle.com> - 2017-05-19 01:40 +0200
[PATCH 16/23] ima/policy: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 16/23] ima/policy: switch to use uuid_t Mimi Zohar <zohar@linux.vnet.ibm.com> - 2017-05-19 01:20 +0200
[PATCH 06/23] uuid: add the v1 layout to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
[PATCH 17/23] fs: switch ->s_uuid to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 17/23] fs: switch ->s_uuid to uuid_t Mimi Zohar <zohar@linux.vnet.ibm.com> - 2017-05-19 01:20 +0200
[PATCH 13/23] md: namespace private helper names Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 13/23] md: namespace private helper names Shaohua Li <shli@kernel.org> - 2017-05-18 20:40 +0200
Re: [PATCH 13/23] md: namespace private helper names Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-22 21:00 +0200
Re: [PATCH 13/23] md: namespace private helper names Christoph Hellwig <hch@lst.de> - 2017-05-23 10:50 +0200
[PATCH 10/23] afs: switch to use uuid_t and uuid_gen Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 10/23] afs: switch to use uuid_t and uuid_gen Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-22 20:50 +0200
Re: [PATCH 10/23] afs: switch to use uuid_t and uuid_gen Christoph Hellwig <hch@lst.de> - 2017-05-23 11:00 +0200
Re: [PATCH 10/23] afs: switch to use uuid_t and uuid_gen Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-23 15:20 +0200
csiph-web