Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1643860
| From | Christoph Hellwig <hch@lst.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 08/23] uuid: hoist uuid_is_null() helper from libnvdimm |
| Date | 2017-05-18 08:40 +0200 |
| Message-ID | <tIngl-6dz-7@gated-at.bofh.it> (permalink) |
| References | <tIn6G-68Z-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hoist the libnvdimm helper as an inline helper to linux/uuid.h
using an auxiliary const variable uuid_null in lib/uuid.c.
[hch: also add the guid variant. Both do the same but I'd like
to keep casts to a minimum]
The common helper uses the new abstract type uuid_t * instead of
u8 *.
Suggested-by: Christoph Hellwig <hch@lst.de>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Cc: David Howells <dhowells@redhat.com>
Signed-off-by: Amir Goldstein <amir73il@gmail.com>
[hch: added guid_is_null]
Signed-off-by: Christoph Hellwig <hch@lst.de>
Acked-by: Dan Williams <dan.j.williams@intel.com>
---
drivers/nvdimm/btt_devs.c | 9 +--------
include/linux/uuid.h | 13 +++++++++++++
lib/uuid.c | 5 +++++
3 files changed, 19 insertions(+), 8 deletions(-)
diff --git a/drivers/nvdimm/btt_devs.c b/drivers/nvdimm/btt_devs.c
index ae00dc0d9791..4c989bb9a8a0 100644
--- a/drivers/nvdimm/btt_devs.c
+++ b/drivers/nvdimm/btt_devs.c
@@ -222,13 +222,6 @@ struct device *nd_btt_create(struct nd_region *nd_region)
return dev;
}
-static bool uuid_is_null(u8 *uuid)
-{
- static const u8 null_uuid[16];
-
- return (memcmp(uuid, null_uuid, 16) == 0);
-}
-
/**
* nd_btt_arena_is_valid - check if the metadata layout is valid
* @nd_btt: device with BTT geometry and backing device info
@@ -249,7 +242,7 @@ bool nd_btt_arena_is_valid(struct nd_btt *nd_btt, struct btt_sb *super)
if (memcmp(super->signature, BTT_SIG, BTT_SIG_LEN) != 0)
return false;
- if (!uuid_is_null(super->parent_uuid))
+ if (!guid_is_null((guid_t *)&super->parent_uuid))
if (memcmp(super->parent_uuid, parent_uuid, 16) != 0)
return false;
diff --git a/include/linux/uuid.h b/include/linux/uuid.h
index 7aff929007dd..47ca06d846d4 100644
--- a/include/linux/uuid.h
+++ b/include/linux/uuid.h
@@ -64,6 +64,9 @@ typedef struct {
*/
#define UUID_STRING_LEN 36
+extern const guid_t guid_null;
+extern const uuid_t uuid_null;
+
static inline bool guid_equal(const guid_t *u1, const guid_t *u2)
{
return memcmp(u1, u2, sizeof(guid_t)) == 0;
@@ -74,6 +77,11 @@ static inline void guid_copy(guid_t *dst, const guid_t *src)
memcpy(dst, src, sizeof(guid_t));
}
+static inline bool guid_is_null(guid_t *guid)
+{
+ return guid_equal(guid, &guid_null);
+}
+
static inline bool uuid_equal(const uuid_t *u1, const uuid_t *u2)
{
return memcmp(u1, u2, sizeof(uuid_t)) == 0;
@@ -84,6 +92,11 @@ static inline void uuid_copy(uuid_t *dst, const uuid_t *src)
memcpy(dst, src, sizeof(uuid_t));
}
+static inline bool uuid_is_null(uuid_t *uuid)
+{
+ return uuid_equal(uuid, &uuid_null);
+}
+
void generate_random_uuid(unsigned char uuid[16]);
extern void guid_gen(guid_t *u);
diff --git a/lib/uuid.c b/lib/uuid.c
index 003bf6823003..25145bfb0eaa 100644
--- a/lib/uuid.c
+++ b/lib/uuid.c
@@ -21,6 +21,11 @@
#include <linux/uuid.h>
#include <linux/random.h>
+const guid_t guid_null;
+EXPORT_SYMBOL(guid_null);
+const uuid_t uuid_null;
+EXPORT_SYMBOL(uuid_null);
+
const u8 guid_index[16] = {3,2,1,0,5,4,7,6,8,9,10,11,12,13,14,15};
const u8 uuid_index[16] = {0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15};
--
2.11.0
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
cleanup UUID types V3 Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 21/23] nvme: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 20/23] sysctl: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 15/23] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
Re: [PATCH 15/23] block: remove blk_part_pack_uuid Mimi Zohar <zohar@linux.vnet.ibm.com> - 2017-05-19 01:20 +0200
[PATCH 23/23] uuid: remove uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
Re: [PATCH 23/23] uuid: remove uuid_be Amir Goldstein <amir73il@gmail.com> - 2017-05-18 10:00 +0200
Re: [PATCH 23/23] uuid: remove uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-18 11:00 +0200
Re: [PATCH 23/23] uuid: remove uuid_be Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-22 21:00 +0200
[PATCH 22/23] scsi_debug: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 01/23] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
Re: [PATCH 01/23] xfs: use uuid_copy() helper to abstract uuid_t Brian Foster <bfoster@redhat.com> - 2017-05-18 15:30 +0200
Re: [PATCH 01/23] xfs: use uuid_copy() helper to abstract uuid_t "Darrick J. Wong" <darrick.wong@oracle.com> - 2017-05-19 01:40 +0200
[PATCH 05/23] uuid: don't export guid_index and uuid_index Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 09/23] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
[PATCH 14/23] xfs: use the common helper uuid_is_null() Christoph Hellwig <hch@lst.de> - 2017-05-18 08:30 +0200
Re: [PATCH 14/23] xfs: use the common helper uuid_is_null() Brian Foster <bfoster@redhat.com> - 2017-05-18 15:30 +0200
[PATCH 19/23] partitions/ldm: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
[PATCH 08/23] uuid: hoist uuid_is_null() helper from libnvdimm Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
[PATCH 11/23] uuid: remove struct uuid_v1 Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
[PATCH 02/23] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 02/23] xfs: use uuid_be to implement the uuid_t type Brian Foster <bfoster@redhat.com> - 2017-05-18 15:30 +0200
Re: [PATCH 02/23] xfs: use uuid_be to implement the uuid_t type "Darrick J. Wong" <darrick.wong@oracle.com> - 2017-05-19 01:40 +0200
[PATCH 12/23] xfs: remove uuid_getnodeuniq and xfs_uu_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 12/23] xfs: remove uuid_getnodeuniq and xfs_uu_t Brian Foster <bfoster@redhat.com> - 2017-05-18 15:30 +0200
Re: [PATCH 12/23] xfs: remove uuid_getnodeuniq and xfs_uu_t "Darrick J. Wong" <darrick.wong@oracle.com> - 2017-05-19 01:40 +0200
[PATCH 16/23] ima/policy: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 16/23] ima/policy: switch to use uuid_t Mimi Zohar <zohar@linux.vnet.ibm.com> - 2017-05-19 01:20 +0200
[PATCH 06/23] uuid: add the v1 layout to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
[PATCH 17/23] fs: switch ->s_uuid to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 17/23] fs: switch ->s_uuid to uuid_t Mimi Zohar <zohar@linux.vnet.ibm.com> - 2017-05-19 01:20 +0200
[PATCH 13/23] md: namespace private helper names Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 13/23] md: namespace private helper names Shaohua Li <shli@kernel.org> - 2017-05-18 20:40 +0200
Re: [PATCH 13/23] md: namespace private helper names Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-22 21:00 +0200
Re: [PATCH 13/23] md: namespace private helper names Christoph Hellwig <hch@lst.de> - 2017-05-23 10:50 +0200
[PATCH 10/23] afs: switch to use uuid_t and uuid_gen Christoph Hellwig <hch@lst.de> - 2017-05-18 08:40 +0200
Re: [PATCH 10/23] afs: switch to use uuid_t and uuid_gen Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-22 20:50 +0200
Re: [PATCH 10/23] afs: switch to use uuid_t and uuid_gen Christoph Hellwig <hch@lst.de> - 2017-05-23 11:00 +0200
Re: [PATCH 10/23] afs: switch to use uuid_t and uuid_gen Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2017-05-23 15:20 +0200
csiph-web