Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1646696
| From | Geert Uytterhoeven <geert@linux-m68k.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v4 5/6] spi: slave: Add SPI slave handler reporting uptime at previous message |
| Date | 2017-05-22 12:20 +0200 |
| Message-ID | <tJSBs-4qg-7@gated-at.bofh.it> (permalink) |
| References | <tI6yR-392-5@gated-at.bofh.it> <tI6yS-392-7@gated-at.bofh.it> <tIw9Y-54I-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Andy,
On Thu, May 18, 2017 at 6:01 PM, Andy Shevchenko
<andy.shevchenko@gmail.com> wrote:
> On Wed, May 17, 2017 at 3:47 PM, Geert Uytterhoeven
> <geert+renesas@glider.be> wrote:
>> Add an example SPI slave handler responding with the uptime at the time
>> of reception of the last SPI message.
>>
>> This can be used by an external microcontroller as a dead man's switch.
>
>> +static int spi_slave_time_submit(struct spi_slave_time_priv *priv)
>> +{
>> + u32 rem_ns;
>> + int ret;
>> + u64 ts;
>> +
>> + ts = local_clock();
>> + rem_ns = do_div(ts, 1000000000) / 1000;
>
> You divide ts by 10^9, which makes it seconds if it was nanoseconds.
>
> But reminder is still in nanoseconds and you divide it by 10^3.
> If I didn't miss anything it should be called like
>
> rem_ns -> reminder_ms
Thanks, that must be a remainder from before I reworked the calculation.
Will change it to rem_us (it's in microseconds, not milliseconds).
>> + priv->buf[0] = cpu_to_be32(ts);
>> + priv->buf[1] = cpu_to_be32(rem_ns);
>> +
>> + spi_message_init_with_transfers(&priv->msg, &priv->xfer, 1);
>> +
>> + priv->msg.complete = spi_slave_time_complete;
>> + priv->msg.context = priv;
>> +
>> + ret = spi_async(priv->spi, &priv->msg);
>> + if (ret)
>> + pr_err("%s: spi_async() failed %d\n", __func__, ret);
>
> Perhaps dev_err() ?
OK, and after that the __func__ is no longer needed.
>> +static int spi_slave_time_probe(struct spi_device *spi)
>> +{
>> + struct spi_slave_time_priv *priv;
>> + int ret;
>> +
>> + /*
>> + * bits_per_word cannot be configured in platform data
>> + */
>> + spi->bits_per_word = 8;
>
> Is it worth to define it? If so, can we use device properties for that?
No, it can be removed, as 8 is the default.
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v4 5/6] spi: slave: Add SPI slave handler reporting uptime at previous message Geert Uytterhoeven <geert+renesas@glider.be> - 2017-05-17 14:50 +0200
Re: [PATCH v4 5/6] spi: slave: Add SPI slave handler reporting uptime at previous message Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-18 18:10 +0200
Re: [PATCH v4 5/6] spi: slave: Add SPI slave handler reporting uptime at previous message Andy Shevchenko <andy.shevchenko@gmail.com> - 2017-05-22 12:20 +0200
Re: [PATCH v4 5/6] spi: slave: Add SPI slave handler reporting uptime at previous message Geert Uytterhoeven <geert@linux-m68k.org> - 2017-05-22 12:20 +0200
csiph-web