Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1643853
| From | Byungchul Park <byungchul.park@lge.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v6 05/15] lockdep: Implement crossrelease feature |
| Date | 2017-05-18 08:30 +0200 |
| Message-ID | <tIn6G-68Z-29@gated-at.bofh.it> (permalink) |
| References | (2 earlier) <txYMh-4vr-3@gated-at.bofh.it> <tzEzL-2JP-1@gated-at.bofh.it> <tzJg6-5J2-27@gated-at.bofh.it> <tA1wm-uN-5@gated-at.bofh.it> <tHLup-6H1-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, May 16, 2017 at 04:18:46PM +0200, Peter Zijlstra wrote: > On Tue, Apr 25, 2017 at 02:40:44PM +0900, Byungchul Park wrote: > > On Mon, Apr 24, 2017 at 12:17:47PM +0200, Peter Zijlstra wrote: > > > > My complaint is mostly about naming.. and "hist_gen_id" might be a > > > better name. > > > > Ah, I also think the name, 'work_id', is not good... and frankly I am > > not sure if 'hist_gen_id' is good, either. What about to apply 'rollback', > > which I did for locks in irq, into works of workqueues? If you say yes, > > I will try to do it. > > If the rollback thing works, that's fine too. If it gets ugly, stick > with something like 'hist_id'. I really want to implement it with rollback.. But it also needs to introduce new fields to distinguish between works which are all normal process contexts. I will do this with renaming instead of applying rollback. Thank you.
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH v6 05/15] lockdep: Implement crossrelease feature Peter Zijlstra <peterz@infradead.org> - 2017-05-16 16:20 +0200 Re: [PATCH v6 05/15] lockdep: Implement crossrelease feature Byungchul Park <byungchul.park@lge.com> - 2017-05-18 08:30 +0200
csiph-web