Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1642562
| From | Michal Hocko <mhocko@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] drm: use kvmalloc_array for drm_malloc* |
| Date | 2017-05-16 15:30 +0200 |
| Message-ID | <tHKI1-69d-1@gated-at.bofh.it> (permalink) |
| References | <tHGEq-3GY-29@gated-at.bofh.it> <tHGXM-3Nc-23@gated-at.bofh.it> <tHHqP-3Wv-29@gated-at.bofh.it> <tHKoG-60M-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue 16-05-17 15:08:56, Daniel Vetter wrote: > On Tue, May 16, 2017 at 11:52:55AM +0200, Michal Hocko wrote: > > On Tue 16-05-17 11:22:30, Daniel Vetter wrote: > > > On Tue, May 16, 2017 at 11:06:06AM +0200, Michal Hocko wrote: > > > > From: Michal Hocko <mhocko@suse.com> > > > > > > > > drm_malloc* has grown their own kmalloc with vmalloc fallback > > > > implementations. MM has grown kvmalloc* helpers in the meantime. Let's > > > > use those because it a) reduces the code and b) MM has a better idea > > > > how to implement fallbacks (e.g. do not vmalloc before kmalloc is tried > > > > with __GFP_NORETRY). > > > > > > > > Signed-off-by: Michal Hocko <mhocko@suse.com> > > > > > > Shouldn't we go one step further and just remove these wrappers, maybe > > > with cocci? > > > > my cocci sucks... > > > > > Especially drm_malloc_gfp is surpremely pointless after this > > > patch (and drm_malloc_ab probably not that useful either). > > > > So what about the following instead? It passes allyesconfig compilation. > > Yeah, looks good, but perhaps rebased onto your first patch. That way we > split the functional change from the refactor (not the first time innocent > looking changes in i915 gem code resulted in surprises). OK, I will split it. > Your patch also seems to need some stuff from -rc1, and atm drm-misc is > still pre-rc1, so I'll pull both patches in once that's sorted (I can do > the rebase myself, since it's rather trivial). But pls remind me in case > it falls through the cracks and isn't in linux-next by end of this week > :-) I have based it on top of the current linux next (next-20170516). Let me know if other tree is more appropriate. -- Michal Hocko SUSE Labs
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] drm: use kvmalloc_array for drm_malloc* Michal Hocko <mhocko@kernel.org> - 2017-05-16 11:10 +0200
Re: [PATCH] drm: use kvmalloc_array for drm_malloc* Daniel Vetter <daniel@ffwll.ch> - 2017-05-16 11:30 +0200
Re: [PATCH] drm: use kvmalloc_array for drm_malloc* Michal Hocko <mhocko@kernel.org> - 2017-05-16 12:00 +0200
Re: [PATCH] drm: use kvmalloc_array for drm_malloc* Michal Hocko <mhocko@kernel.org> - 2017-05-16 15:30 +0200
Re: [PATCH] drm: use kvmalloc_array for drm_malloc* Chris Wilson <chris@chris-wilson.co.uk> - 2017-05-16 11:40 +0200
Re: [PATCH] drm: use kvmalloc_array for drm_malloc* Michal Hocko <mhocko@kernel.org> - 2017-05-16 13:00 +0200
Re: [PATCH] drm: use kvmalloc_array for drm_malloc* Chris Wilson <chris@chris-wilson.co.uk> - 2017-05-16 13:10 +0200
Re: [PATCH] drm: use kvmalloc_array for drm_malloc* Michal Hocko <mhocko@kernel.org> - 2017-05-17 09:50 +0200
Re: [PATCH] drm: use kvmalloc_array for drm_malloc* Chris Wilson <chris@chris-wilson.co.uk> - 2017-05-17 10:10 +0200
Re: [PATCH] drm: use kvmalloc_array for drm_malloc* Michal Hocko <mhocko@kernel.org> - 2017-05-17 10:20 +0200
csiph-web