Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1638264
| From | Kees Cook <keescook@chromium.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] key: Convert big_key payload.data to struct |
| Date | 2017-05-09 18:20 +0200 |
| Message-ID | <tFg1I-45Y-29@gated-at.bofh.it> (permalink) |
| References | <tEYHw-Wn-19@gated-at.bofh.it> <tEZ0S-1js-11@gated-at.bofh.it> <tEZke-1sP-7@gated-at.bofh.it> <tF8xb-7xS-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, May 9, 2017 at 1:11 AM, David Howells <dhowells@redhat.com> wrote: > Kees Cook <keescook@chromium.org> wrote: > >> This doesn't protect you against changes in struct path size, >> though... the existing code (and this proposal) will break if that >> ever happens... > > True - in which case you should kmalloc() it as Eric suggests. > >> What's the problem with defining the types at the top level? That >> seems like a nice place to see them all at once. > > It means adding a bunch of dependencies to linux/key.h and union key_payload. > > Have you considered why we don't just put all the definitions for all the > filesystems in linux/fs.h? By this logic it would seem like a nice place to > see them all at once. I've seen other things that want to share a structure use embedded structures, etc. I'll see if there is something else to be done, but just cleaning up the casts alone makes the big_key code so much more readable. :P -Kees -- Kees Cook Pixel Security
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] key: Convert big_key payload.data to struct Kees Cook <keescook@chromium.org> - 2017-05-08 23:50 +0200
Re: [PATCH] key: Convert big_key payload.data to struct David Howells <dhowells@redhat.com> - 2017-05-09 00:10 +0200
Re: [PATCH] key: Convert big_key payload.data to struct Kees Cook <keescook@chromium.org> - 2017-05-09 00:30 +0200
Re: [PATCH] key: Convert big_key payload.data to struct David Howells <dhowells@redhat.com> - 2017-05-09 10:20 +0200
Re: [PATCH] key: Convert big_key payload.data to struct Kees Cook <keescook@chromium.org> - 2017-05-09 18:20 +0200
Re: [PATCH] key: Convert big_key payload.data to struct Eric Biggers <ebiggers3@gmail.com> - 2017-05-09 00:30 +0200
Re: [PATCH] key: Convert big_key payload.data to struct David Howells <dhowells@redhat.com> - 2017-05-09 09:30 +0200
Re: [PATCH] key: Convert big_key payload.data to struct Eric Biggers <ebiggers3@gmail.com> - 2017-05-09 23:50 +0200
csiph-web