Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1633829

Re: [PATCH 2/2 v2] input: touchscreen: ar1021_i2c: use BIT to check for a bit

From Dmitry Torokhov <dmitry.torokhov@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 2/2 v2] input: touchscreen: ar1021_i2c: use BIT to check for a bit
Date 2017-05-01 21:40 +0200
Message-ID <tCpkS-4KF-17@gated-at.bofh.it> (permalink)
References <tAQIy-xM-15@gated-at.bofh.it> <tC2Rj-7gG-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sun, Apr 30, 2017 at 09:38:53PM +0200, Martin Kepplinger wrote:
> The MSB for the first byte of touch data transmission is always 1. Make
> it a little more obvious we're testing this bit by using BIT(7).
> 
> Signed-off-by: Martin Kepplinger <martink@posteo.de>

Applied, thank you.

> ---
> 
> I'd still use the definition :) but otherwise I'd write the following.
> It really doesn't matter though.
> 
> thanks for the quick support Dmitry,
> 
>                     martin
> 
> 
>  drivers/input/touchscreen/ar1021_i2c.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/input/touchscreen/ar1021_i2c.c b/drivers/input/touchscreen/ar1021_i2c.c
> index eb1874fe52c2..8c76aa435903 100644
> --- a/drivers/input/touchscreen/ar1021_i2c.c
> +++ b/drivers/input/touchscreen/ar1021_i2c.c
> @@ -44,7 +44,7 @@ static irqreturn_t ar1021_i2c_irq(int irq, void *dev_id)
>  		goto out;
>  
>  	/* sync bit set ? */
> -	if ((data[0] & 0x80) == 0)
> +	if (!(data[0] & BIT(7)))
>  		goto out;
>  
>  	button = data[0] & BIT(0);
> -- 
> 2.11.0
> 

-- 
Dmitry

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/2] input: touchscreen: ar1021_i2c: enable touch mode during open Martin Kepplinger <martin.kepplinger@ginzinger.com> - 2017-04-27 14:30 +0200
  [PATCH 2/2] input: touchscreen: ar1021_i2c: replace magic number with definition Martin Kepplinger <martin.kepplinger@ginzinger.com> - 2017-04-27 14:30 +0200
    Re: [PATCH 2/2] input: touchscreen: ar1021_i2c: replace magic number  with definition Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-04-28 19:10 +0200
    [PATCH 2/2 v2] input: touchscreen: ar1021_i2c: use BIT to check for a bit Martin Kepplinger <martink@posteo.de> - 2017-04-30 21:40 +0200
      Re: [PATCH 2/2 v2] input: touchscreen: ar1021_i2c: use BIT to check  for a bit Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-05-01 21:40 +0200
  Re: [PATCH 1/2] input: touchscreen: ar1021_i2c: enable touch mode  during open Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-04-28 19:10 +0200

csiph-web