Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1633033

Re: [PATCH 2/2] input: touchscreen: ar1021_i2c: replace magic number with definition

From Dmitry Torokhov <dmitry.torokhov@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 2/2] input: touchscreen: ar1021_i2c: replace magic number with definition
Date 2017-04-28 19:10 +0200
Message-ID <tBhz4-1Yt-23@gated-at.bofh.it> (permalink)
References <tAQIx-xM-5@gated-at.bofh.it> <tAQIy-xM-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, Apr 27, 2017 at 02:22:36PM +0200, Martin Kepplinger wrote:
> We now have a few of this device's definitions. Let's avoid magic numbers
> and use them.
> 
> Signed-off-by: Martin Kepplinger <martin.kepplinger@ginzinger.com>
> ---
>  drivers/input/touchscreen/ar1021_i2c.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/input/touchscreen/ar1021_i2c.c b/drivers/input/touchscreen/ar1021_i2c.c
> index 2a76231..edd5268 100644
> --- a/drivers/input/touchscreen/ar1021_i2c.c
> +++ b/drivers/input/touchscreen/ar1021_i2c.c
> @@ -44,7 +44,7 @@ static irqreturn_t ar1021_i2c_irq(int irq, void *dev_id)
>  		goto out;
>  
>  	/* sync bit set ? */
> -	if ((data[0] & 0x80) == 0)
> +	if ((data[0] & AR1021_TOUCH) == 0)

I'd rather have it as "(data & BIT(7))". This constant does not provide
any better meaning than number 0x80. At least the latter shows that we
test the MSB or the first byte, while the former obfuscates it.

Thanks.

-- 
Dmitry

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/2] input: touchscreen: ar1021_i2c: enable touch mode during open Martin Kepplinger <martin.kepplinger@ginzinger.com> - 2017-04-27 14:30 +0200
  [PATCH 2/2] input: touchscreen: ar1021_i2c: replace magic number with definition Martin Kepplinger <martin.kepplinger@ginzinger.com> - 2017-04-27 14:30 +0200
    Re: [PATCH 2/2] input: touchscreen: ar1021_i2c: replace magic number  with definition Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-04-28 19:10 +0200
    [PATCH 2/2 v2] input: touchscreen: ar1021_i2c: use BIT to check for a bit Martin Kepplinger <martink@posteo.de> - 2017-04-30 21:40 +0200
      Re: [PATCH 2/2 v2] input: touchscreen: ar1021_i2c: use BIT to check  for a bit Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-05-01 21:40 +0200
  Re: [PATCH 1/2] input: touchscreen: ar1021_i2c: enable touch mode  during open Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2017-04-28 19:10 +0200

csiph-web