Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1634788
| From | Nikola Pajkovsky <npajkovsky@suse.cz> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 0/6] md: Fine-tuning for some function implementations |
| Date | 2017-05-03 09:40 +0200 |
| Message-ID | <tCX3c-1Uk-7@gated-at.bofh.it> (permalink) |
| References | <tCGYp-7Na-3@gated-at.bofh.it> <tCNGx-3EW-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
NeilBrown <neilb@suse.com> writes:
> On Tue, May 02 2017, SF Markus Elfring wrote:
>
>> From: Markus Elfring <elfring@users.sourceforge.net>
>> Date: Tue, 2 May 2017 16:12:34 +0200
>>
>> Some update suggestions were taken into account
>> from static source code analysis.
>>
>> Markus Elfring (6):
>> Replace seven seq_printf() calls by seq_putc()
>> Replace 17 seq_printf() calls by seq_puts()
>
> Why does anyone care whether printf or putc/puts is used? Really it
> doesn't matter *at* *all*.
It could matter, but this patchset does not state it all. Does not
have any perf tests and so on.
f7a5f132b447 ("proc: faster /proc/*/status")
68ba0326b4e1 ("proc: much faster /proc/vmstat")
> I don't object to the patch but if it would up to me I probably wouldn't
> bother applying it it either.
> Sometimes I just want to "print" something and I don't want to care
> whether it is a constant string or a single-byte constant string, or
> something more general.
> I see these changes as worse than white-space fixes.
>
> NeilBrown
>
>
>> Adjust four function calls together with a variable assignment
>> Use seq_puts() in faulty_status()
>> Adjust six function calls together with a variable assignment in faulty_status()
>> Add some spaces for better code readability
>>
>> drivers/md/faulty.c | 48 ++++++++++++++++++++++----------------
>> drivers/md/md.c | 66 +++++++++++++++++++++++++++++------------------------
>> 2 files changed, 64 insertions(+), 50 deletions(-)
>>
>> --
>> 2.12.2
--
Nikola
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 0/6] md: Fine-tuning for some function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-05-02 16:30 +0200
[PATCH 6/6] md: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-05-02 16:40 +0200
Re: [PATCH 0/6] md: Fine-tuning for some function implementations NeilBrown <neilb@suse.com> - 2017-05-02 23:40 +0200
Re: [PATCH 0/6] md: Fine-tuning for some function implementations Nikola Pajkovsky <npajkovsky@suse.cz> - 2017-05-03 09:40 +0200
csiph-web