Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1573693
| From | Vivien Didelot <vivien.didelot@savoirfairelinux.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH net-next 2/6] net: dsa: simplify netdevice events handling |
| Date | 2017-02-04 17:20 +0100 |
| Message-ID | <t7bea-2Tv-17@gated-at.bofh.it> (permalink) |
| References | <t6QMp-5eA-1@gated-at.bofh.it> <t6QMq-5eA-29@gated-at.bofh.it> <t6YAh-2o4-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Florian,
Florian Fainelli <f.fainelli@gmail.com> writes:
>> - if (dsa_slave_dev_check(dev))
>> - return dsa_slave_port_event(dev, event, ptr);
>> + if (dev->netdev_ops != &dsa_slave_netdev_ops)
>> + return NOTIFY_DONE;
>
> Why not keep the dsa_slave_dev_check() here?
I dropped it because that condition feels more readable to me than
!dsa_slave_dev_check(dev).
Thanks,
Vivien
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH net-next 0/6] net: dsa: add fabric notifier Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-02-03 19:30 +0100
[PATCH net-next 4/6] net: dsa: change state setter scope Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-02-03 19:30 +0100
[PATCH net-next 3/6] net: dsa: rollback bridging on error Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-02-03 19:30 +0100
[PATCH net-next 6/6] net: dsa: introduce bridge notifier Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-02-03 19:30 +0100
Re: [PATCH net-next 6/6] net: dsa: introduce bridge notifier Andrew Lunn <andrew@lunn.ch> - 2017-02-04 19:00 +0100
Re: [PATCH net-next 6/6] net: dsa: introduce bridge notifier Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-02-04 19:30 +0100
Re: [PATCH net-next 6/6] net: dsa: introduce bridge notifier Andrew Lunn <andrew@lunn.ch> - 2017-02-04 19:40 +0100
[PATCH net-next 5/6] net: dsa: add switch notifier Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-02-03 19:30 +0100
[PATCH net-next 1/6] net: dsa: move netdevice notifier registration Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-02-03 19:30 +0100
[PATCH net-next 2/6] net: dsa: simplify netdevice events handling Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-02-03 19:30 +0100
Re: [PATCH net-next 2/6] net: dsa: simplify netdevice events handling Florian Fainelli <f.fainelli@gmail.com> - 2017-02-04 03:50 +0100
Re: [PATCH net-next 2/6] net: dsa: simplify netdevice events handling Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-02-04 17:20 +0100
Re: [PATCH net-next 0/6] net: dsa: add fabric notifier David Miller <davem@davemloft.net> - 2017-02-06 23:00 +0100
csiph-web