Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1571886
| From | Mark Brown <broonie@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v4 3/3] spi: acpi: Initialize modalias from of_compatible |
| Date | 2017-02-01 19:40 +0100 |
| Message-ID | <t67Z0-Zl-7@gated-at.bofh.it> (permalink) |
| References | <t2PYB-mQ-3@gated-at.bofh.it> <t4eUW-4Ja-11@gated-at.bofh.it> <t4eUW-4Ja-19@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Multipart message — attachments visible in raw view] - view raw
On Fri, Jan 27, 2017 at 01:30:15PM +0000, Dan O'Donovan wrote: > + if (acpi_of_modalias(adev, spi->modalias, sizeof(spi->modalias))) > + strlcpy(spi->modalias, acpi_device_hid(adev), > + sizeof(spi->modalias)); I can't help but think that this would be simpler to use if the interface were something like acpi_set_modalias() and it did the fallback to the ACPI HID internally. It'd both avoid a small amount of code duplication and make the code read a bit more naturally - I have to think to realise that this means "if there isn't an OF name use the HID" since it looks like a boolean function. Then again just putting a != 0 in the test would have the same effect probably.
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH v4 3/3] spi: acpi: Initialize modalias from of_compatible Mark Brown <broonie@kernel.org> - 2017-02-01 19:40 +0100
csiph-web