Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1567537
| From | Peter Zijlstra <peterz@infradead.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] x86/fpu: Unify the naming of the FPU register cache validity flags |
| Date | 2017-01-26 16:40 +0100 |
| Message-ID | <t3Ujw-Eh-31@gated-at.bofh.it> (permalink) |
| References | <t3QpA-6Hl-9@gated-at.bofh.it> <t3QpB-6Hl-41@gated-at.bofh.it> <t3TdM-8u9-23@gated-at.bofh.it> <t3TGP-cu-25@gated-at.bofh.it> <t3TQu-uN-19@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, Jan 26, 2017 at 04:05:25PM +0100, Ingo Molnar wrote:
> diff --git a/arch/x86/include/asm/switch_to.h b/arch/x86/include/asm/switch_to.h
> index a7146dadb31d..7a4915dd0547 100644
> --- a/arch/x86/include/asm/switch_to.h
> +++ b/arch/x86/include/asm/switch_to.h
> @@ -78,7 +78,7 @@ do { \
> */
> static inline void arch_task_migrate(struct task_struct *p)
> {
> - p->thread.fpu.fpregs_cached = 0;
> + p->thread.fpu.fpregs_owner = 0;
> }
> #define arch_task_migrate arch_task_migrate
I still really dislike having this callback..
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/7] x86/fpu: Simplify the FPU state machine Ingo Molnar <mingo@kernel.org> - 2017-01-26 12:30 +0100
[PATCH 4/7] x86/fpu: Split the state handling in fpu__drop() Ingo Molnar <mingo@kernel.org> - 2017-01-26 12:30 +0100
[PATCH 7/7] x86/fpu: Remove struct fpu::fpregs_active Ingo Molnar <mingo@kernel.org> - 2017-01-26 12:30 +0100
[PATCH 2/7] x86/fpu: Simplify fpu->fpregs_active use Ingo Molnar <mingo@kernel.org> - 2017-01-26 12:30 +0100
Re: [PATCH 2/7] x86/fpu: Simplify fpu->fpregs_active use Andy Lutomirski <luto@amacapital.net> - 2017-01-26 17:40 +0100
[PATCH 1/7] x86/fpu: Simplify the fpu->last_cpu logic and rename it to fpu->fpregs_cached Ingo Molnar <mingo@kernel.org> - 2017-01-26 12:30 +0100
Re: [PATCH 1/7] x86/fpu: Simplify the fpu->last_cpu logic and rename it to fpu->fpregs_cached Rik van Riel <riel@redhat.com> - 2017-01-26 15:30 +0100
Re: [PATCH 1/7] x86/fpu: Simplify the fpu->last_cpu logic and rename it to fpu->fpregs_cached Ingo Molnar <mingo@kernel.org> - 2017-01-26 16:00 +0100
[PATCH] x86/fpu: Unify the naming of the FPU register cache validity flags Ingo Molnar <mingo@kernel.org> - 2017-01-26 16:10 +0100
Re: [PATCH] x86/fpu: Unify the naming of the FPU register cache validity flags Peter Zijlstra <peterz@infradead.org> - 2017-01-26 16:40 +0100
Re: [PATCH 1/7] x86/fpu: Simplify the fpu->last_cpu logic and rename it to fpu->fpregs_cached Rik van Riel <riel@redhat.com> - 2017-01-26 16:00 +0100
Re: [PATCH 1/7] x86/fpu: Simplify the fpu->last_cpu logic and rename it to fpu->fpregs_cached Ingo Molnar <mingo@kernel.org> - 2017-01-26 16:20 +0100
Re: [PATCH 1/7] x86/fpu: Simplify the fpu->last_cpu logic and rename it to fpu->fpregs_cached Andy Lutomirski <luto@amacapital.net> - 2017-01-26 18:00 +0100
csiph-web