Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1564800
| From | Johannes Thumshirn <jthumshirn@suse.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/5] blk-throttle: Move three assignments for the variable "ret" in tg_set_max() |
| Date | 2017-01-23 10:20 +0100 |
| Message-ID | <t2IX8-4Ae-19@gated-at.bofh.it> (permalink) |
| References | <t2lQR-6Vp-9@gated-at.bofh.it> <t2lQS-6Vp-17@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sun, Jan 22, 2017 at 09:31:29AM +0100, SF Markus Elfring wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Sat, 21 Jan 2017 21:23:06 +0100
>
> A local variable was set to an error code before a concrete error situation
> was detected. Thus move the corresponding assignments into if branches
> to indicate a software failure there.
>
> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
> ---
> block/blk-throttle.c | 23 +++++++++++++----------
> 1 file changed, 13 insertions(+), 10 deletions(-)
>
> diff --git a/block/blk-throttle.c b/block/blk-throttle.c
> index 6f4c96e5f86b..51d112deb02e 100644
> --- a/block/blk-throttle.c
> +++ b/block/blk-throttle.c
> @@ -1327,27 +1327,30 @@ static ssize_t tg_set_max(struct kernfs_open_file *of,
> break;
> ctx.body += len;
>
> - ret = -EINVAL;
> p = tok;
> strsep(&p, "=");
> - if (!p || (sscanf(p, "%llu", &val) != 1 && strcmp(p, "max")))
> + if (!p || (sscanf(p, "%llu", &val) != 1 && strcmp(p, "max"))) {
> + ret = -EINVAL;
> goto out_finish;
> + }
Sorry, I don't like this patch. We know the next error if we encounter one
will be EINVAL until we change it. Your patch doesn't introduce a functual
change and doesn't improve readability, so I don't really see a point for it.
Byte,
Johannes
--
Johannes Thumshirn Storage
jthumshirn@suse.de +49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 1/5] blk-throttle: Move three assignments for the variable "ret" in tg_set_max() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-22 09:40 +0100
Re: [PATCH 1/5] blk-throttle: Move three assignments for the variable "ret" in tg_set_max() Johannes Thumshirn <jthumshirn@suse.de> - 2017-01-23 10:20 +0100
Re: [PATCH 1/5] blk-throttle: Move three assignments for the variable "ret" in tg_set_max() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-23 11:10 +0100
Re: [PATCH 1/5] blk-throttle: Move three assignments for the variable "ret" in tg_set_max() Johannes Thumshirn <jthumshirn@suse.de> - 2017-01-23 12:50 +0100
Re: blk-throttle: Move three assignments for the variable "ret" in tg_set_max() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-23 13:10 +0100
Re: blk-throttle: Move three assignments for the variable "ret" in tg_set_max() Jens Axboe <axboe@kernel.dk> - 2017-01-23 16:20 +0100
csiph-web