Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1504949
| From | Mark Rutland <mark.rutland@arm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file |
| Date | 2016-10-20 16:50 +0200 |
| Message-ID | <sumPn-t0-7@gated-at.bofh.it> (permalink) |
| References | <smrCx-1LD-3@gated-at.bofh.it> <smrMf-1Po-61@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi,
On Thu, Sep 29, 2016 at 02:17:09AM +0800, fu.wei@linaro.org wrote:
> diff --git a/include/clocksource/arm_arch_timer.h b/include/clocksource/arm_arch_timer.h
> index caedb74..6f06481 100644
> --- a/include/clocksource/arm_arch_timer.h
> +++ b/include/clocksource/arm_arch_timer.h
> @@ -19,6 +19,9 @@
Please add:
#include <linux/bitops.h>
... immediately before the includes below; it's needed to ensure that
BIT() is defined in all cases. Previously we were relying on implicit
header includes, which is not good practice.
> #include <linux/timecounter.h>
> #include <linux/types.h>
>
> +#define ARCH_CP15_TIMER BIT(0)
> +#define ARCH_MEM_TIMER BIT(1)
If we're going to expose these in a header, it would be better to rename
them to something that makes their usage/meaning clear. These should
probably be ARCH_TIMER_TYPE_{CP15,MEM}.
I guess this can wait for subsequent cleanup.
> +enum ppi_nr {
> + PHYS_SECURE_PPI,
> + PHYS_NONSECURE_PPI,
> + VIRT_PPI,
> + HYP_PPI,
> + MAX_TIMER_PPI
> +};
Please rename this to arch_timer_ppi_nr (updating the single user in
drivers/clocksource/arm_arch_timer.c). That'll avoid the potential for
name clashes in files this happens to get included in (potentially
transitively via other headers).
With those changes (regardless of the ARCH_TIMER_TYPE_* bits):
Acked-by: Mark Rutland <mark.rutland@arm.com>
Thanks,
Mark.
> +
> #define ARCH_TIMER_PHYS_ACCESS 0
> #define ARCH_TIMER_VIRT_ACCESS 1
> #define ARCH_TIMER_MEM_PHYS_ACCESS 2
> --
> 2.7.4
>
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file Mark Rutland <mark.rutland@arm.com> - 2016-10-20 16:50 +0200
Re: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file Fu Wei <fu.wei@linaro.org> - 2016-10-26 10:40 +0200
Re: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file Mark Rutland <mark.rutland@arm.com> - 2016-10-26 13:00 +0200
Re: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file Fu Wei <fu.wei@linaro.org> - 2016-10-26 13:00 +0200
csiph-web