Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1506288

Re: [PATCH] flow_dissector: avoid uninitialized variable access

From Arnd Bergmann <arnd@arndb.de>
Newsgroups linux.kernel
Subject Re: [PATCH] flow_dissector: avoid uninitialized variable access
Date 2016-10-21 23:10 +0200
Message-ID <suPeF-2CB-5@gated-at.bofh.it> (permalink)
References <suKoG-7Ei-15@gated-at.bofh.it> <suL1o-8bl-25@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Friday, October 21, 2016 6:31:18 PM CEST Jiri Pirko wrote:
> Fri, Oct 21, 2016 at 05:55:53PM CEST, arnd@arndb.de wrote:
> >gcc warns about an uninitialized pointer dereference in the vlan
> >priority handling:
> >
> >net/core/flow_dissector.c: In function '__skb_flow_dissect':
> >net/core/flow_dissector.c:281:61: error: 'vlan' may be used uninitialized in this function [-Werror=maybe-uninitialized]
> >
> >From all I can tell, this warning is about a real bug, and we
> >should not attempt look up the vlan header if there was
> >no vlan tag.
> 
> I don't see how vlan could be used uninitialized. But I understand that
> this is impossible for gcc to track it. Please just use uninitialized_var()
> 

I usually try to avoid uninitialized_var(), as making it obvious to
the compiler why something is known tends to result in more readable
source code and better object code.

Can you explain why "dissector_uses_key(flow_dissector,
FLOW_DISSECTOR_KEY_VLAN) && skb_vlan_tag_present(skb)" implies
"eth_type_vlan(proto))"?

If I add uninitialized_var() here, I would at least put that in
a comment here.

On a related note, I also don't see how
"dissector_uses_key(flow_dissector, FLOW_DISSECTOR_KEY_VLAN)"
implies that skb is non-NULL. I guess this is related to the
first one.

	Arnd

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] flow_dissector: avoid uninitialized variable access Arnd Bergmann <arnd@arndb.de> - 2016-10-21 18:00 +0200
  Re: [PATCH] flow_dissector: avoid uninitialized variable access Jiri Pirko <jiri@resnulli.us> - 2016-10-21 18:40 +0200
    Re: [PATCH] flow_dissector: avoid uninitialized variable access Arnd Bergmann <arnd@arndb.de> - 2016-10-21 23:10 +0200
      Re: [PATCH] flow_dissector: avoid uninitialized variable access Arnd Bergmann <arnd@arndb.de> - 2016-10-22 00:20 +0200
        Re: [PATCH] flow_dissector: avoid uninitialized variable access Eric Garver <e@erig.me> - 2016-10-22 18:00 +0200
          Re: [PATCH] flow_dissector: avoid uninitialized variable access Tom Herbert <tom@herbertland.com> - 2016-10-22 20:30 +0200
            [PATCH net-next] flow_dissector: fix vlan tag handling Arnd Bergmann <arnd@arndb.de> - 2016-10-23 22:00 +0200
              Re: [PATCH net-next] flow_dissector: fix vlan tag handling Jiri Pirko <jiri@resnulli.us> - 2016-10-24 10:20 +0200
                Re: [PATCH net-next] flow_dissector: fix vlan tag handling Arnd Bergmann <arnd@arndb.de> - 2016-10-24 18:10 +0200
    Re: [PATCH] flow_dissector: avoid uninitialized variable access Linus Torvalds <torvalds@linux-foundation.org> - 2016-10-22 03:50 +0200
      Re: [PATCH] flow_dissector: avoid uninitialized variable access Jiri Pirko <jiri@resnulli.us> - 2016-10-22 09:00 +0200

csiph-web