Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1474108
| From | Zhen Lei <thunder.leizhen@huawei.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v8 06/16] of_numa: Use of_get_next_parent to simplify code |
| Date | 2016-09-01 09:00 +0200 |
| Message-ID | <scu8G-5sK-33@gated-at.bofh.it> (permalink) |
| References | <scu8F-5sK-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Kefeng Wang <wangkefeng.wang@huawei.com>
Use of_get_next_parent() instead of open-code.
Signed-off-by: Kefeng Wang <wangkefeng.wang@huawei.com>
Acked-by: Rob Herring <robh@kernel.org>
---
drivers/of/of_numa.c | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/drivers/of/of_numa.c b/drivers/of/of_numa.c
index 625b057..0d7459b 100644
--- a/drivers/of/of_numa.c
+++ b/drivers/of/of_numa.c
@@ -158,8 +158,6 @@ int of_node_to_nid(struct device_node *device)
np = of_node_get(device);
while (np) {
- struct device_node *parent;
-
r = of_property_read_u32(np, "numa-node-id", &nid);
/*
* -EINVAL indicates the property was not found, and
@@ -170,9 +168,7 @@ int of_node_to_nid(struct device_node *device)
if (r != -EINVAL)
break;
- parent = of_get_parent(np);
- of_node_put(np);
- np = parent;
+ np = of_get_next_parent(np);
}
if (np && r)
pr_warn("NUMA: Invalid \"numa-node-id\" property in node %s\n",
--
2.5.0
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v8 00/16] fix some type infos and bugs for arm64/of numa Zhen Lei <thunder.leizhen@huawei.com> - 2016-09-01 09:00 +0200
[PATCH v8 05/16] arm64/numa: avoid inconsistent information to be printed Zhen Lei <thunder.leizhen@huawei.com> - 2016-09-01 09:00 +0200
[PATCH v8 07/16] of_numa: Use pr_fmt() Zhen Lei <thunder.leizhen@huawei.com> - 2016-09-01 09:00 +0200
[PATCH v8 04/16] of/numa: remove a duplicated warning Zhen Lei <thunder.leizhen@huawei.com> - 2016-09-01 09:00 +0200
[PATCH v8 10/16] mm/memblock: add a new function memblock_alloc_near_nid Zhen Lei <thunder.leizhen@huawei.com> - 2016-09-01 09:00 +0200
Re: [PATCH v8 10/16] mm/memblock: add a new function memblock_alloc_near_nid "Leizhen (ThunderTown)" <thunder.leizhen@huawei.com> - 2016-09-09 06:00 +0200
[PATCH v8 12/16] arm64/numa: remove some useless code Zhen Lei <thunder.leizhen@huawei.com> - 2016-09-01 09:00 +0200
[PATCH v8 06/16] of_numa: Use of_get_next_parent to simplify code Zhen Lei <thunder.leizhen@huawei.com> - 2016-09-01 09:00 +0200
[PATCH v8 16/16] arm64/numa: define numa_distance as array to simplify code Zhen Lei <thunder.leizhen@huawei.com> - 2016-09-01 09:00 +0200
[PATCH v8 01/16] of/numa: remove a duplicated pr_debug information Zhen Lei <thunder.leizhen@huawei.com> - 2016-09-01 09:10 +0200
[PATCH v8 02/16] of/numa: fix a memory@ node can only contains one memory block Zhen Lei <thunder.leizhen@huawei.com> - 2016-09-01 09:10 +0200
Re: [PATCH v8 00/16] fix some type infos and bugs for arm64/of numa Will Deacon <will.deacon@arm.com> - 2016-09-08 13:10 +0200
Re: [PATCH v8 00/16] fix some type infos and bugs for arm64/of numa "Leizhen (ThunderTown)" <thunder.leizhen@huawei.com> - 2016-09-09 04:10 +0200
csiph-web