Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1471881

Re: [PATCH v2] ARM: imx: use IS_ENABLED() instead of checking for built-in or module

From Shawn Guo <shawnguo@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v2] ARM: imx: use IS_ENABLED() instead of checking for built-in or module
Date 2016-08-29 16:30 +0200
Message-ID <sbvJw-8ra-25@gated-at.bofh.it> (permalink)
References <sbrPz-626-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, Aug 29, 2016 at 12:12:04PM +0200, Javier Martinez Canillas wrote:
> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
> 
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
> 
> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

Applied, thanks.

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH v2] ARM: imx: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-29 12:20 +0200
  Re: [PATCH v2] ARM: imx: use IS_ENABLED() instead of checking for  built-in or module Shawn Guo <shawnguo@kernel.org> - 2016-08-29 16:30 +0200

csiph-web