Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1557442
| From | Arnd Bergmann <arnd@arndb.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h |
| Date | 2017-01-12 14:20 +0100 |
| Message-ID | <sYNsn-4qh-49@gated-at.bofh.it> (permalink) |
| References | <sYMcV-3w1-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thursday, January 12, 2017 11:56:34 AM CET David Howells wrote:
> Move the afs_uuid struct to linux/uuid.h and rename it to uuid_v1.
>
> Signed-off-by: David Howells <dhowells@redhat.com>
>
Looks good to me, but I wonder if this part:
r = call->request;
- r->time_low = ntohl(b[0]);
- r->time_mid = ntohl(b[1]);
- r->time_hi_and_version = ntohl(b[2]);
+ r->time_low = b[0];
+ r->time_mid = htons(ntohl(b[1]));
+ r->time_hi_and_version = htons(ntohl(b[2]));
r->clock_seq_hi_and_reserved = ntohl(b[3]);
r->clock_seq_low = ntohl(b[4]);
should be considered a bugfix and split out into a
separate patch. From what I understand about the mess in UUID
formats, the time fields can either be big-endian (as defined)
or little-endian (for all things Microsoft), and you are changing
the representation from CPU-specific to big-endian, which makes
it different for x86 and most ARM at least.
Arnd
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 1/2] afs: Move UUID struct to linux/uuid.h David Howells <dhowells@redhat.com> - 2017-01-12 13:00 +0100
[PATCH 2/2] afs: Use core kernel UUID generation David Howells <dhowells@redhat.com> - 2017-01-12 13:00 +0100
Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h Arnd Bergmann <arnd@arndb.de> - 2017-01-12 14:20 +0100
Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h David Howells <dhowells@redhat.com> - 2017-01-12 15:30 +0100
Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h Arnd Bergmann <arnd@arndb.de> - 2017-01-12 16:50 +0100
Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h David Howells <dhowells@redhat.com> - 2017-01-12 17:20 +0100
Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h Arnd Bergmann <arnd@arndb.de> - 2017-01-12 17:30 +0100
Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h David Howells <dhowells@redhat.com> - 2017-01-12 17:50 +0100
csiph-web