Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1557248

Re: [PATCH v5 1/5] powernv:idle: Add IDLE_STATE_ENTER_SEQ_NORET macro

From Balbir Singh <bsingharora@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH v5 1/5] powernv:idle: Add IDLE_STATE_ENTER_SEQ_NORET macro
Date 2017-01-12 10:50 +0100
Message-ID <sYKb7-2kU-5@gated-at.bofh.it> (permalink)
References <sY0KZ-7Ue-3@gated-at.bofh.it> <sY0L0-7Ue-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Jan 10, 2017 at 02:37:00PM +0530, Gautham R. Shenoy wrote:
> From: "Gautham R. Shenoy" <ego@linux.vnet.ibm.com>
> 
> Currently all the low-power idle states are expected to wake up
> at reset vector 0x100. Which is why the macro IDLE_STATE_ENTER_SEQ
> that puts the CPU to an idle state and never returns.
> 
> On ISA v3.0, when the ESL and EC bits in the PSSCR are zero, the CPU
> is expected to wake up at the next instruction of the idle
> instruction.
> 
> This patch adds a new macro named IDLE_STATE_ENTER_SEQ_NORET for the
> no-return variant and reuses the name IDLE_STATE_ENTER_SEQ
> for a variant that allows resuming operation at the instruction next
> to the idle-instruction.
> 
> Signed-off-by: Gautham R. Shenoy <ego@linux.vnet.ibm.com>
> ---
> No changes from v4
>

Acked-by: Balbir Singh <bsingharora@gmail.com> 

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v5 0/5] powernv:stop: Use psscr_val,mask provided by firmware "Gautham R. Shenoy" <ego@linux.vnet.ibm.com> - 2017-01-10 10:20 +0100
  [PATCH v5 5/5] Documentation:powerpc: Add device-tree bindings for power-mgt "Gautham R. Shenoy" <ego@linux.vnet.ibm.com> - 2017-01-10 10:20 +0100
    Re: [PATCH v5 5/5] Documentation:powerpc: Add device-tree bindings  for power-mgt Rob Herring <robh@kernel.org> - 2017-01-13 18:10 +0100
  [PATCH v5 2/5] powernv:stop: Uniformly rename power9 to arch300 "Gautham R. Shenoy" <ego@linux.vnet.ibm.com> - 2017-01-10 10:20 +0100
    Re: [PATCH v5 2/5] powernv:stop: Uniformly rename power9 to arch300 Balbir Singh <bsingharora@gmail.com> - 2017-01-12 11:00 +0100
      Re: [PATCH v5 2/5] powernv:stop: Uniformly rename power9 to arch300 Gautham R Shenoy <ego@linux.vnet.ibm.com> - 2017-01-13 04:50 +0100
        Re: [PATCH v5 2/5] powernv:stop: Uniformly rename power9 to arch300 "Oliver O'Halloran" <oohall@gmail.com> - 2017-01-13 04:50 +0100
  [PATCH v5 1/5] powernv:idle: Add IDLE_STATE_ENTER_SEQ_NORET macro "Gautham R. Shenoy" <ego@linux.vnet.ibm.com> - 2017-01-10 10:20 +0100
    Re: [PATCH v5 1/5] powernv:idle: Add IDLE_STATE_ENTER_SEQ_NORET macro Balbir Singh <bsingharora@gmail.com> - 2017-01-12 10:50 +0100
  [PATCH v5 4/5] powernv: Pass PSSCR value and mask to power9_idle_stop "Gautham R. Shenoy" <ego@linux.vnet.ibm.com> - 2017-01-10 10:20 +0100
    Re: [PATCH v5 4/5] powernv: Pass PSSCR value and mask to  power9_idle_stop Balbir Singh <bsingharora@gmail.com> - 2017-01-12 18:40 +0100

csiph-web