Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1542334
| From | Tom Herbert <tom@herbertland.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function |
| Date | 2016-12-15 00:20 +0100 |
| Message-ID | <sOr06-6CZ-9@gated-at.bofh.it> (permalink) |
| References | (2 earlier) <sOnfQ-2vz-19@gated-at.bofh.it> <sOnzc-2MP-35@gated-at.bofh.it> <sOoOB-49J-1@gated-at.bofh.it> <sOprk-4Yt-25@gated-at.bofh.it> <sOqGK-6gP-25@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, Dec 14, 2016 at 2:56 PM, Jason A. Donenfeld <Jason@zx2c4.com> wrote: > Hey Tom, > > On Wed, Dec 14, 2016 at 10:35 PM, Tom Herbert <tom@herbertland.com> wrote: >> Those look good, although I would probably just do 1,2,3 words and >> then have a function that takes n words like jhash. Might want to call >> these dword to distinguish from 32 bit words in jhash. > > So actually jhash_Nwords makes no sense, since it takes dwords > (32-bits) not words (16-bits). The siphash analog should be called > siphash24_Nqwords. > Yeah, that's a "bug" with jhash function names. > I think what I'll do is change what I already have to: > siphash24_1qword > siphash24_2qword > siphash24_3qword > siphash24_4qword > > And then add some static inline helpers to assist with smaller u32s > like ipv4 addresses called: > > siphash24_2dword > siphash24_4dword > siphash24_6dword > siphash24_8dword > > While we're having something new, might as well call it the right thing. > I'm confused, doesn't 2dword == 1qword? Anyway, I think the qword functions are good enough. If someone needs to hash over some odd length they can either put them in a structure padded to 64 bits or call the hash function that takes a byte length. > >> Also, what is the significance of "24" in the function and constant >> names? Can we just drop that and call this siphash? > > SipHash is actually a family of PRFs, differentiated by the number of > SIPROUNDs after each 64-bit input is processed and the number of > SIPROUNDs at the very end of the function. The best trade-off of speed > and security for kernel usage is 2 rounds after each 64-bit input and > 4 rounds at the end of the function. This doesn't fall to any known > cryptanalysis and it's very fast. I'd still drop the "24" unless you really think we're going to have multiple variants coming into the kernel. Tom
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 1/4] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 05:10 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-14 12:40 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 14:20 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-14 16:20 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 20:50 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Herbert Xu <herbert@gondor.apana.org.au> - 2016-12-15 09:00 +0100
Re: [kernel-hardening] Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Daniel Micay <danielmicay@gmail.com> - 2016-12-15 09:20 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 13:50 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-14 23:10 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 00:40 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-15 09:40 +0100
RE: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function David Laight <David.Laight@ACULAB.COM> - 2016-12-15 12:10 +0100
RE: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function David Laight <David.Laight@ACULAB.COM> - 2016-12-15 13:30 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-15 14:00 +0100
RE: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function David Laight <David.Laight@ACULAB.COM> - 2016-12-15 15:00 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-15 16:00 +0100
RE: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function David Laight <David.Laight@ACULAB.COM> - 2016-12-15 16:50 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-15 17:00 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 20:00 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-15 21:40 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 21:50 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-15 22:20 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-15 22:20 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Peter Zijlstra <peterz@infradead.org> - 2016-12-15 23:10 +0100
Re: [kernel-hardening] Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 22:20 +0100
Re: [kernel-hardening] Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Linus Torvalds <torvalds@linux-foundation.org> - 2016-12-15 22:20 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Peter Zijlstra <peterz@infradead.org> - 2016-12-15 22:20 +0100
Re: [PATCH v2 1/4] siphash: add cryptographically secure hashtable function Hannes Frederic Sowa <hannes@stressinduktion.org> - 2016-12-15 13:30 +0100
[PATCH v3 2/3] secure_seq: use siphash24 instead of md5_transform "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 19:50 +0100
Re: [PATCH v3 2/3] secure_seq: use siphash24 instead of md5_transform kbuild test robot <lkp@intel.com> - 2016-12-14 22:50 +0100
[PATCH v3 1/3] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 19:50 +0100
[PATCH v3 3/3] random: use siphash24 instead of md5 for get_random_int/long "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 19:50 +0100
Re: [PATCH v3 3/3] random: use siphash24 instead of md5 for get_random_int/long kbuild test robot <lkp@intel.com> - 2016-12-14 23:00 +0100
Re: [PATCH v3 3/3] random: use siphash24 instead of md5 for get_random_int/long kbuild test robot <lkp@intel.com> - 2016-12-14 23:10 +0100
RE: [PATCH v3 3/3] random: use siphash24 instead of md5 for get_random_int/long David Laight <David.Laight@ACULAB.COM> - 2016-12-15 11:20 +0100
Re: [PATCH v3 3/3] random: use siphash24 instead of md5 for get_random_int/long "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 20:00 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function Tom Herbert <tom@herbertland.com> - 2016-12-14 20:20 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 20:40 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 22:00 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function Tom Herbert <tom@herbertland.com> - 2016-12-14 22:40 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 00:00 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 00:20 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function Christian Kujau <lists@nerdbynature.de> - 2016-12-18 01:10 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function Tom Herbert <tom@herbertland.com> - 2016-12-15 00:20 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 00:40 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function Linus Torvalds <torvalds@linux-foundation.org> - 2016-12-15 01:30 +0100
RE: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function David Laight <David.Laight@ACULAB.COM> - 2016-12-15 11:30 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function Linus Torvalds <torvalds@linux-foundation.org> - 2016-12-15 00:40 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function kbuild test robot <lkp@intel.com> - 2016-12-14 22:20 +0100
Re: [PATCH v3 1/3] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-14 22:30 +0100
[PATCH v4 3/4] secure_seq: use siphash instead of md5_transform "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 02:50 +0100
[PATCH v4 2/4] siphash: add N[qd]word helpers "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 02:50 +0100
[PATCH v4 4/4] random: use siphash instead of MD5 for get_random_int/long "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 02:50 +0100
[PATCH v4 1/4] siphash: add cryptographically secure hashtable function "Jason A. Donenfeld" <Jason@zx2c4.com> - 2016-12-15 02:50 +0100
csiph-web