Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1542842
| From | Pali Rohár <pali.rohar@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 3/7] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set() |
| Date | 2016-12-15 16:50 +0100 |
| Message-ID | <sOGsa-7xD-21@gated-at.bofh.it> (permalink) |
| References | <sM69r-68W-7@gated-at.bofh.it> <sM69r-68W-5@gated-at.bofh.it> <sN9RD-6wJ-5@gated-at.bofh.it> <sOFw6-6Xv-19@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu Dec 15 15:46:28 2016 Michał Kępień <kernel@kempniu.pl> wrote: > > On Thursday 08 December 2016 13:36:14 Michał Kępień wrote: > > > --- a/sound/pci/hda/dell_wmi_helper.c > > > +++ b/sound/pci/hda/dell_wmi_helper.c > > > @@ -6,7 +6,7 @@ > > > #include <linux/dell-led.h> > > > > > > static int dell_led_value; > > > -static int (*dell_led_set_func)(int, int); > > > +static int (*dell_led_set_func)(int); > > > > Suggestion: what about changing name to dell_micmute_led_set_func to > > match real function name which is used after this patch? > > While I like the idea itself, implementing it will double the number of > lines that this patch changes (6 vs. 12), arguably making its intention If some patch makes final result of code better then metric number of lines is not priority. > less clear. Please let me know if you would really like this to happen > (perhaps as a separate patch?), otherwise I will skip this idea in v2. > > -- > Best regards, > Michał Kępień If it will be in this or another following patch... I dot care. But this is sound subsystem, so sound maintainers need to decide what they prefer. -- Pali Rohár pali.rohar@gmail.com
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH 3/7] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set() Pali Rohár <pali.rohar@gmail.com> - 2016-12-11 11:50 +0100
Re: [PATCH 3/7] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set() Michał Kępień <kernel@kempniu.pl> - 2016-12-15 15:50 +0100
Re: [PATCH 3/7] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set() Pali Rohár <pali.rohar@gmail.com> - 2016-12-15 16:50 +0100
Re: [PATCH 3/7] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set() Michał Kępień <kernel@kempniu.pl> - 2016-12-15 20:50 +0100
csiph-web