Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1539367

Re: [PATCH 1/2] tracing/kprobes: add a helper method to return number of probe hits

From Steven Rostedt <rostedt@goodmis.org>
Newsgroups linux.kernel
Subject Re: [PATCH 1/2] tracing/kprobes: add a helper method to return number of probe hits
Date 2016-12-09 15:10 +0100
Message-ID <sMu26-4gD-7@gated-at.bofh.it> (permalink)
References <sMstj-3bv-1@gated-at.bofh.it> <sMu25-4gD-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, 9 Dec 2016 09:00:52 -0500
Steven Rostedt <rostedt@goodmis.org> wrote:

> On Fri, 9 Dec 2016 13:25:51 +0100
> Marcin Nowakowski <marcin.nowakowski@imgtec.com> wrote:
> 
> > The number of probe hits is stored in a percpu variable and therefore
> > can't be read directly. Add a helper method trace_kprobe_nhit() that
> > performs the required calculation.  
> 
> Can you please add the "why?" to this change log. Who needs this
> functionality, and why?
> 

I should have specified, even if the next patch uses the functionality,
each patch's change log should stand on its own. In the future, when
people do git blame, they wont be seeing patch series. They will only
see the change log of the one change.

-- Steve

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/2] tracing/kprobes: add a helper method to return number of probe hits Marcin Nowakowski <marcin.nowakowski@imgtec.com> - 2016-12-09 13:30 +0100
  [PATCH 2/2] kprobes/trace: Fix kprobe selftest for newer gcc Marcin Nowakowski <marcin.nowakowski@imgtec.com> - 2016-12-09 13:30 +0100
  Re: [PATCH 1/2] tracing/kprobes: add a helper method to return  number of probe hits Steven Rostedt <rostedt@goodmis.org> - 2016-12-09 15:10 +0100
    Re: [PATCH 1/2] tracing/kprobes: add a helper method to return  number of probe hits Steven Rostedt <rostedt@goodmis.org> - 2016-12-09 15:10 +0100
      Re: [PATCH 1/2] tracing/kprobes: add a helper method to return number  of probe hits Marcin Nowakowski <marcin.nowakowski@imgtec.com> - 2016-12-09 15:10 +0100

csiph-web