Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1539315

[PATCH 1/2] tracing/kprobes: add a helper method to return number of probe hits

From Marcin Nowakowski <marcin.nowakowski@imgtec.com>
Newsgroups linux.kernel
Subject [PATCH 1/2] tracing/kprobes: add a helper method to return number of probe hits
Date 2016-12-09 13:30 +0100
Message-ID <sMstj-3bv-1@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


The number of probe hits is stored in a percpu variable and therefore
can't be read directly. Add a helper method trace_kprobe_nhit() that
performs the required calculation.

Signed-off-by: Marcin Nowakowski <marcin.nowakowski@imgtec.com>
---
 kernel/trace/trace_kprobe.c | 19 +++++++++++++------
 1 file changed, 13 insertions(+), 6 deletions(-)

diff --git a/kernel/trace/trace_kprobe.c b/kernel/trace/trace_kprobe.c
index eb6c9f1..a2af1bc 100644
--- a/kernel/trace/trace_kprobe.c
+++ b/kernel/trace/trace_kprobe.c
@@ -73,6 +73,17 @@ static nokprobe_inline bool trace_kprobe_is_on_module(struct trace_kprobe *tk)
 	return !!strchr(trace_kprobe_symbol(tk), ':');
 }
 
+static nokprobe_inline unsigned long trace_kprobe_nhit(struct trace_kprobe *tk)
+{
+	unsigned long nhit = 0;
+	int cpu;
+
+	for_each_possible_cpu(cpu)
+		nhit += *per_cpu_ptr(tk->nhit, cpu);
+
+	return nhit;
+}
+
 static int register_kprobe_event(struct trace_kprobe *tk);
 static int unregister_kprobe_event(struct trace_kprobe *tk);
 
@@ -882,14 +893,10 @@ static const struct file_operations kprobe_events_ops = {
 static int probes_profile_seq_show(struct seq_file *m, void *v)
 {
 	struct trace_kprobe *tk = v;
-	unsigned long nhit = 0;
-	int cpu;
-
-	for_each_possible_cpu(cpu)
-		nhit += *per_cpu_ptr(tk->nhit, cpu);
 
 	seq_printf(m, "  %-44s %15lu %15lu\n",
-		   trace_event_name(&tk->tp.call), nhit,
+		   trace_event_name(&tk->tp.call),
+		   trace_kprobe_nhit(tk),
 		   tk->rp.kp.nmissed);
 
 	return 0;
-- 
2.7.4

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 1/2] tracing/kprobes: add a helper method to return number of probe hits Marcin Nowakowski <marcin.nowakowski@imgtec.com> - 2016-12-09 13:30 +0100
  [PATCH 2/2] kprobes/trace: Fix kprobe selftest for newer gcc Marcin Nowakowski <marcin.nowakowski@imgtec.com> - 2016-12-09 13:30 +0100
  Re: [PATCH 1/2] tracing/kprobes: add a helper method to return  number of probe hits Steven Rostedt <rostedt@goodmis.org> - 2016-12-09 15:10 +0100
    Re: [PATCH 1/2] tracing/kprobes: add a helper method to return  number of probe hits Steven Rostedt <rostedt@goodmis.org> - 2016-12-09 15:10 +0100
      Re: [PATCH 1/2] tracing/kprobes: add a helper method to return number  of probe hits Marcin Nowakowski <marcin.nowakowski@imgtec.com> - 2016-12-09 15:10 +0100

csiph-web