Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1529689
| From | Sergio Paracuellos <sergio.paracuellos@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 2/2] staging: slicoss: remove UPDATE_STATS_GB macro and inline code |
| Date | 2016-11-24 21:40 +0100 |
| Message-ID | <sH8Yh-7HV-1@gated-at.bofh.it> (permalink) |
| References | <sH7Sx-6Zu-9@gated-at.bofh.it> <sH7Sx-6Zu-7@gated-at.bofh.it> <sH8bU-76f-35@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, Nov 24, 2016 at 8:41 PM, Markus Böhme <markus.boehme@mailbox.org> wrote:
> On 11/24/2016 08:21 PM, Sergio Paracuellos wrote:
>> This patch removes UPDATE_STATS_GB macro in slic.h header file
>> and just inline code. This improve readability.
>>
>> Signed-off-by: Sergio Paracuellos <sergio.paracuellos@gmail.com>
>> ---
>> drivers/staging/slicoss/slic.h | 5 ----
>> drivers/staging/slicoss/slicoss.c | 52 +++++++++++++++++++--------------------
>> 2 files changed, 25 insertions(+), 32 deletions(-)
>>
>> diff --git a/drivers/staging/slicoss/slic.h b/drivers/staging/slicoss/slic.h
>> index 2c05868..2893bdf 100644
>> --- a/drivers/staging/slicoss/slic.h
>> +++ b/drivers/staging/slicoss/slic.h
>> @@ -548,11 +548,6 @@ static inline void slic_flush_write(struct adapter *adapter)
>> ioread32(adapter->regs + SLIC_REG_HOSTID);
>> }
>>
>> -#define UPDATE_STATS_GB(largestat, newstat, oldstat) \
>> -{ \
>> - (largestat) += ((newstat) - (oldstat)); \
>> -}
>> -
>> #if BITS_PER_LONG == 64
>> #define SLIC_GET_ADDR_LOW(_addr) (u32)((u64)(_addr) & \
>> 0x00000000FFFFFFFF)
>> diff --git a/drivers/staging/slicoss/slicoss.c b/drivers/staging/slicoss/slicoss.c
>> index b6ec0a1..ffc7c45 100644
>> --- a/drivers/staging/slicoss/slicoss.c
>> +++ b/drivers/staging/slicoss/slicoss.c
>> @@ -1014,45 +1014,43 @@ static void slic_upr_request_complete(struct adapter *adapter, u32 isr)
>> break;
>> }
>>
>> - UPDATE_STATS_GB(stst->tcp.xmit_tcp_segs, stats->xmit_tcp_segs,
>> - old->xmit_tcp_segs);
>> + stst->tcp.xmit_tcp_segs =
>> + stats->xmit_tcp_segs - old->xmit_tcp_segs;
>
> Missed this the first time, but the difference should be added to the
> value in stst:
>
> stst->tcp.xmit_tcp_segs +=
> stats->xmit_tcp_segs - old->xmit_tcp_segs;
>
> The same applies to the changes below.
True. I have just sent v3 with these fixed.
Thanks for let me know.
Cheers,
Sergio Paracuellos
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v2 2/2] staging: slicoss: remove UPDATE_STATS_GB macro and inline code Sergio Paracuellos <sergio.paracuellos@gmail.com> - 2016-11-24 20:30 +0100
Re: [PATCH v2 2/2] staging: slicoss: remove UPDATE_STATS_GB macro and inline code Markus Böhme <markus.boehme@mailbox.org> - 2016-11-24 20:50 +0100
Re: [PATCH v2 2/2] staging: slicoss: remove UPDATE_STATS_GB macro and inline code Sergio Paracuellos <sergio.paracuellos@gmail.com> - 2016-11-24 21:40 +0100
csiph-web