Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1529051
| From | "Michael Kerrisk (man-pages)" <mtk.manpages@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/4] statx: Add a system call to make enhanced file info available [ver #3] |
| Date | 2016-11-24 09:20 +0100 |
| Message-ID | <sGXqa-92-23@gated-at.bofh.it> (permalink) |
| References | <sGu4N-6a5-5@gated-at.bofh.it> <sGu4N-6a5-3@gated-at.bofh.it> <sGBfY-2uO-19@gated-at.bofh.it> <sGOGd-2vZ-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Andreas, On 11/23/2016 11:57 PM, Andreas Dilger wrote: > On Nov 23, 2016, at 1:37 AM, Michael Kerrisk <mtk.manpages@gmail.com> wrote: >> [...] >>> =============== >>> NEW SYSTEM CALL >>> =============== >>> >>> The new system call is: >>> >>> int ret = statx(int dfd, >>> const char *filename, >>> unsigned int flags, >> >> In the 0/4 of this patch series, this argument is called 'atflags'. >> These should be consistent. 'flags' seems correct to me. > > Given that there are a number of different flags and masks in use for > this syscall, naming this field "atflags" makes it more clear what it > is used for. Well, yes, but in all of the "at" calls the argument is just flags. So, better to be consistent in that dimension, I'd say, and then make sure we perhaps have meaningfil names for the fiellds, as you suggest next: >>> unsigned int mask, > > Similarly, naming this field "request_mask" would also be more clear, > and matches what is used elsewhere in the code. > > That said, I don't care enough about this detail to request a patch refresh, > but it would be useful for the man pages. -- Michael Kerrisk Linux man-pages maintainer; http://www.kernel.org/doc/man-pages/ Linux/UNIX System Programming Training: http://man7.org/training/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC][PATCH 0/4] Enhanced file stat system call [ver #3] David Howells <dhowells@redhat.com> - 2016-11-23 02:00 +0100
[PATCH 4/4] statx: AFS: Return enhanced file attributes [ver #3] David Howells <dhowells@redhat.com> - 2016-11-23 02:10 +0100
Re: [PATCH 4/4] statx: AFS: Return enhanced file attributes [ver #3] Andreas Dilger <adilger@dilger.ca> - 2016-11-24 03:10 +0100
Re: [PATCH 1/4] statx: Add a system call to make enhanced file info available [ver #3] "Michael Kerrisk (man-pages)" <mtk.manpages@gmail.com> - 2016-11-23 09:40 +0100
Re: [PATCH 1/4] statx: Add a system call to make enhanced file info available [ver #3] Andreas Dilger <adilger@dilger.ca> - 2016-11-23 23:50 +0100
Re: [PATCH 1/4] statx: Add a system call to make enhanced file info available [ver #3] Andreas Dilger <adilger@dilger.ca> - 2016-11-24 00:00 +0100
Re: [PATCH 1/4] statx: Add a system call to make enhanced file info available [ver #3] "Michael Kerrisk (man-pages)" <mtk.manpages@gmail.com> - 2016-11-24 09:20 +0100
Re: [PATCH 1/4] statx: Add a system call to make enhanced file info available [ver #3] David Howells <dhowells@redhat.com> - 2016-11-24 08:40 +0100
csiph-web