Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1516501
| From | Joel Holdsworth <joel@airwebreathe.org.uk> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v8 2/3] Documentation: Add binding document for Lattice iCE40 FPGA manager |
| Date | 2016-11-07 20:10 +0100 |
| Message-ID | <sAXsS-7ns-27@gated-at.bofh.it> (permalink) |
| References | <sAIk9-5nz-3@gated-at.bofh.it> <sAIk9-5nz-1@gated-at.bofh.it> <sAWQ9-6UY-27@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
>> + cdone-gpios = <&gpio 24 GPIO_ACTIVE_HIGH>; >> + reset-gpios = <&gpio 22 GPIO_ACTIVE_LOW>; > > Wouldn't it make more sense to have "gpios" and "gpio-names" ? That > scales better imo, although in this case we cannot really talk about > scaling. > I don't believe that would be conventional. '-gpios' seems to be the standard over '-gpio' even for a single GPIO. Having multiple GPIOs in that field is only relevant when it could be an array e.g. multiple chip-select GPIO lines. Not for multiple GPIOs with differing functions. Also it doesn't fit with the way devm_gpiod_get works where you select GPIO(s) from the device-tree, and specify whether it's an input or an output. In this case one is an output, one is an input. Joel
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v8 2/3] Documentation: Add binding document for Lattice iCE40 FPGA manager Joel Holdsworth <joel@airwebreathe.org.uk> - 2016-11-07 04:00 +0100
Re: [PATCH v8 2/3] Documentation: Add binding document for Lattice iCE40 FPGA manager Marek Vasut <marex@denx.de> - 2016-11-07 19:30 +0100
Re: [PATCH v8 2/3] Documentation: Add binding document for Lattice iCE40 FPGA manager Joel Holdsworth <joel@airwebreathe.org.uk> - 2016-11-07 20:10 +0100
csiph-web