Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1461772

Re: [PATCH v3 0/7] x86: Rewrite switch_to()

From Brian Gerst <brgerst@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH v3 0/7] x86: Rewrite switch_to()
Date 2016-08-14 12:30 +0200
Message-ID <s5YXU-5oj-29@gated-at.bofh.it> (permalink)
References <s5K8x-3J2-9@gated-at.bofh.it> <s5KLg-4dd-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sat, Aug 13, 2016 at 1:16 PM, Linus Torvalds
<torvalds@linux-foundation.org> wrote:
> On Sat, Aug 13, 2016 at 9:38 AM, Brian Gerst <brgerst@gmail.com> wrote:
>> This patch set simplifies the switch_to() code, by moving the stack switch
>> code out of line into an asm stub before calling __switch_to().  This ends
>> up being more readable, and using the C calling convention instead of
>> clobbering all registers improves code generation.  It also allows newly
>> forked processes to construct a special stack frame to seamlessly flow
>> to ret_from_fork, instead of using a test and branch, or an unbalanced
>> call/ret.
>
> Do you have performance numbers? Is it noticeable/measurable?

How do I measure it?  The perf documentation isn't easy to understand.

It shouldn't be a significant change.  On a 64-bit defconfig build,
__schedule() shrinks by 103 bytes.  It's hard to analyse what exactly
changes, but it's likely that GCC can allocate registers better
without all the clobbers of the old inline asm version interfering.
The new stub adds just 39 bytes.

--
Brian Gerst

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v3 0/7] x86: Rewrite switch_to() Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:40 +0200
  [PATCH v3 1/7] x86-32, kgdb: Don't use thread.ip in sleeping_thread_to_gdb_regs() Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:40 +0200
    [tip:x86/asm] sched/x86/32, kgdb: Don't use thread.ip in  sleeping_thread_to_gdb_regs() tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:50 +0200
  [PATCH v3 7/7] Revert "sched: Mark __schedule() stack frame as non-standard" Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:40 +0200
    [tip:x86/asm] sched: Remove __schedule() non-standard frame  annotation tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:50 +0200
  [PATCH v3 2/7] x86-64, kgdb: clear GDB_PS on 64-bit Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:40 +0200
    [tip:x86/asm] sched/x86/64, kgdb: Clear GDB_PS on 64-bit tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:50 +0200
  [PATCH v3 3/7] x86: Add struct inactive_task_frame Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:40 +0200
    [tip:x86/asm] sched/x86: Add 'struct inactive_task_frame' to better  document the sleeping task stack frame tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:20 +0200
  [PATCH v3 4/7] x86: Rewrite switch_to() code Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:50 +0200
    [tip:x86/asm] sched/x86: Rewrite the switch_to() code tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:20 +0200
  [PATCH v3 6/7] x86: Fix thread_saved_pc() Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:50 +0200
    [tip:x86/asm] sched/x86: Fix thread_saved_pc() tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:20 +0200
  Re: [PATCH v3 0/7] x86: Rewrite switch_to() Linus Torvalds <torvalds@linux-foundation.org> - 2016-08-13 19:20 +0200
    Re: [PATCH v3 0/7] x86: Rewrite switch_to() Ingo Molnar <mingo@kernel.org> - 2016-08-14 10:30 +0200
      Re: [PATCH v3 0/7] x86: Rewrite switch_to() Andy Lutomirski <luto@amacapital.net> - 2016-08-14 13:20 +0200
        Re: [PATCH v3 0/7] x86: Rewrite switch_to() Herbert Xu <herbert@gondor.apana.org.au> - 2016-08-17 07:20 +0200
      Re: [PATCH v3 0/7] x86: Rewrite switch_to() Brian Gerst <brgerst@gmail.com> - 2016-08-14 16:20 +0200
        Re: [PATCH v3 0/7] x86: Rewrite switch_to() Ingo Molnar <mingo@kernel.org> - 2016-08-15 07:20 +0200
          Re: [PATCH v3 0/7] x86: Rewrite switch_to() Brian Gerst <brgerst@gmail.com> - 2016-08-15 13:50 +0200
          Re: [PATCH v3 0/7] x86: Rewrite switch_to() Andy Lutomirski <luto@amacapital.net> - 2016-08-17 23:30 +0200
    Re: [PATCH v3 0/7] x86: Rewrite switch_to() Brian Gerst <brgerst@gmail.com> - 2016-08-14 12:30 +0200
  Re: [PATCH v3 0/7] x86: Rewrite switch_to() Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-17 23:30 +0200

csiph-web