Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1461644
| From | Brian Gerst <brgerst@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v3 0/7] x86: Rewrite switch_to() |
| Date | 2016-08-13 18:40 +0200 |
| Message-ID | <s5K8x-3J2-9@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
This patch set simplifies the switch_to() code, by moving the stack switch code out of line into an asm stub before calling __switch_to(). This ends up being more readable, and using the C calling convention instead of clobbering all registers improves code generation. It also allows newly forked processes to construct a special stack frame to seamlessly flow to ret_from_fork, instead of using a test and branch, or an unbalanced call/ret. Changes from v2: - Updated comments around kernel threads being uncommon for fork, etc. - Removed STACK_FRAME_NON_STANDARD annotation from __schedule() per Josh Poimboeuf - A few minor cleanups added Changes from v1: - Added struct inactive_task_frame - Added comments about kernel threads returning to userspace - Cleaned up some incorrect uses of thread.sp - Rearranged inactive stack frame so that BP (frame pointer) is in the natural position right below the return address. This should take care of unwinding issues Josh raised. Brian Gerst (7): x86-32, kgdb: Don't use thread.ip in sleeping_thread_to_gdb_regs() x86-64, kgdb: clear GDB_PS on 64-bit x86: Add struct inactive_task_frame x86: Rewrite switch_to() code x86: Pass kernel thread parameters in fork_frame x86: Fix thread_saved_pc() Revert "sched: Mark __schedule() stack frame as non-standard" arch/x86/entry/entry_32.S | 68 +++++++++++++----- arch/x86/entry/entry_64.S | 78 ++++++++++++++------ arch/x86/include/asm/processor.h | 13 +--- arch/x86/include/asm/stacktrace.h | 4 +- arch/x86/include/asm/switch_to.h | 144 ++++++++----------------------------- arch/x86/include/asm/thread_info.h | 2 - arch/x86/kernel/asm-offsets.c | 6 ++ arch/x86/kernel/asm-offsets_32.c | 5 ++ arch/x86/kernel/asm-offsets_64.c | 5 ++ arch/x86/kernel/kgdb.c | 8 +-- arch/x86/kernel/process.c | 14 +++- arch/x86/kernel/process_32.c | 31 +++----- arch/x86/kernel/process_64.c | 21 +++--- arch/x86/kernel/smpboot.c | 1 - kernel/sched/core.c | 1 - 15 files changed, 190 insertions(+), 211 deletions(-) -- 2.5.5
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v3 0/7] x86: Rewrite switch_to() Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:40 +0200
[PATCH v3 1/7] x86-32, kgdb: Don't use thread.ip in sleeping_thread_to_gdb_regs() Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:40 +0200
[tip:x86/asm] sched/x86/32, kgdb: Don't use thread.ip in sleeping_thread_to_gdb_regs() tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:50 +0200
[PATCH v3 7/7] Revert "sched: Mark __schedule() stack frame as non-standard" Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:40 +0200
[tip:x86/asm] sched: Remove __schedule() non-standard frame annotation tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:50 +0200
[PATCH v3 2/7] x86-64, kgdb: clear GDB_PS on 64-bit Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:40 +0200
[tip:x86/asm] sched/x86/64, kgdb: Clear GDB_PS on 64-bit tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:50 +0200
[PATCH v3 3/7] x86: Add struct inactive_task_frame Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:40 +0200
[tip:x86/asm] sched/x86: Add 'struct inactive_task_frame' to better document the sleeping task stack frame tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:20 +0200
[PATCH v3 4/7] x86: Rewrite switch_to() code Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:50 +0200
[tip:x86/asm] sched/x86: Rewrite the switch_to() code tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:20 +0200
[PATCH v3 6/7] x86: Fix thread_saved_pc() Brian Gerst <brgerst@gmail.com> - 2016-08-13 18:50 +0200
[tip:x86/asm] sched/x86: Fix thread_saved_pc() tip-bot for Brian Gerst <tipbot@zytor.com> - 2016-08-24 15:20 +0200
Re: [PATCH v3 0/7] x86: Rewrite switch_to() Linus Torvalds <torvalds@linux-foundation.org> - 2016-08-13 19:20 +0200
Re: [PATCH v3 0/7] x86: Rewrite switch_to() Ingo Molnar <mingo@kernel.org> - 2016-08-14 10:30 +0200
Re: [PATCH v3 0/7] x86: Rewrite switch_to() Andy Lutomirski <luto@amacapital.net> - 2016-08-14 13:20 +0200
Re: [PATCH v3 0/7] x86: Rewrite switch_to() Herbert Xu <herbert@gondor.apana.org.au> - 2016-08-17 07:20 +0200
Re: [PATCH v3 0/7] x86: Rewrite switch_to() Brian Gerst <brgerst@gmail.com> - 2016-08-14 16:20 +0200
Re: [PATCH v3 0/7] x86: Rewrite switch_to() Ingo Molnar <mingo@kernel.org> - 2016-08-15 07:20 +0200
Re: [PATCH v3 0/7] x86: Rewrite switch_to() Brian Gerst <brgerst@gmail.com> - 2016-08-15 13:50 +0200
Re: [PATCH v3 0/7] x86: Rewrite switch_to() Andy Lutomirski <luto@amacapital.net> - 2016-08-17 23:30 +0200
Re: [PATCH v3 0/7] x86: Rewrite switch_to() Brian Gerst <brgerst@gmail.com> - 2016-08-14 12:30 +0200
Re: [PATCH v3 0/7] x86: Rewrite switch_to() Josh Poimboeuf <jpoimboe@redhat.com> - 2016-08-17 23:30 +0200
csiph-web