Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1455874

RE: [PATCH 0071/1285] Replace numeric parameter like 0444 with macro

From David Laight <David.Laight@ACULAB.COM>
Newsgroups linux.kernel
Subject RE: [PATCH 0071/1285] Replace numeric parameter like 0444 with macro
Date 2016-08-03 18:00 +0200
Message-ID <s26Km-4pi-9@gated-at.bofh.it> (permalink)
References <s1G3w-3Jf-25@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Baole Ni
> Sent: 02 August 2016 11:39
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
...
> -module_param(debug, ulong, 0644);
> +module_param(debug, ulong, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
...

If you're as old as I am the octal constant is easier to read!

	David

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 0071/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 13:30 +0200
  RE: [PATCH 0071/1285] Replace numeric parameter like 0444 with macro David Laight <David.Laight@ACULAB.COM> - 2016-08-03 18:00 +0200

csiph-web