Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1455586
| From | Rusty Russell <rusty@rustcorp.com.au> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 0309/1285] Replace numeric parameter like 0444 with macro |
| Date | 2016-08-03 04:40 +0200 |
| Message-ID | <s1Ug9-4Hs-5@gated-at.bofh.it> (permalink) |
| References | <s1I5k-54A-49@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Baole Ni <baolex.ni@intel.com> writes: > I find that the developers often just specified the numeric value > when calling a macro which is defined with a parameter for access permission. > As we know, these numeric value for access permission have had the corresponding macro, > and that using macro can improve the robustness and readability of the code, > thus, I suggest replacing the numeric parameter with the macro. I find the numbers far, far more readable. Cheers, Rusty. > /* Allow Guests to use a non-128 (ie. non-Linux) syscall trap. */ > static unsigned int syscall_vector = IA32_SYSCALL_VECTOR; > -module_param(syscall_vector, uint, 0444); > +module_param(syscall_vector, uint, S_IRUSR | S_IRGRP | S_IROTH); > > /* The address of the interrupt handler is split into two bits: */ > static unsigned long idt_address(u32 lo, u32 hi) > -- > 2.9.2
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 0309/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 15:40 +0200 Re: [PATCH 0309/1285] Replace numeric parameter like 0444 with macro Rusty Russell <rusty@rustcorp.com.au> - 2016-08-03 04:40 +0200
csiph-web