Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1455173
| From | Dmitry Torokhov <dmitry.torokhov@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 0290/1285] Replace numeric parameter like 0444 with macro |
| Date | 2016-08-02 19:40 +0200 |
| Message-ID | <s1LPB-7DB-73@gated-at.bofh.it> (permalink) |
| References | <s1GmS-3Sw-57@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Aug 02, 2016 at 06:57:11PM +0800, Baole Ni wrote: > I find that the developers often just specified the numeric value > when calling a macro which is defined with a parameter for access permission. > As we know, these numeric value for access permission have had the corresponding macro, > and that using macro can improve the robustness and readability of the code, > thus, I suggest replacing the numeric parameter with the macro. > > Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com> > Signed-off-by: Baole Ni <baolex.ni@intel.com> > --- > drivers/input/touchscreen/ads7846.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/input/touchscreen/ads7846.c b/drivers/input/touchscreen/ads7846.c > index a61b215..0f882cb 100644 > --- a/drivers/input/touchscreen/ads7846.c > +++ b/drivers/input/touchscreen/ads7846.c > @@ -591,7 +591,7 @@ static ssize_t ads7846_disable_store(struct device *dev, > return count; > } > > -static DEVICE_ATTR(disable, 0664, ads7846_disable_show, ads7846_disable_store); > +static DEVICE_ATTR(disable, S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH, ads7846_disable_show, ads7846_disable_store); No, this does not improve neither robustness nor readability. Thanks. -- Dmitry
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 0290/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 13:50 +0200
Re: [PATCH 0290/1285] Replace numeric parameter like 0444 with macro Mark Brown <broonie@kernel.org> - 2016-08-02 16:40 +0200
Re: [PATCH 0290/1285] Replace numeric parameter like 0444 with macro "Andrew F. Davis" <afd@ti.com> - 2016-08-02 17:00 +0200
Re: [PATCH 0290/1285] Replace numeric parameter like 0444 with macro Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2016-08-02 19:40 +0200
csiph-web