Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1385874

Re: [PATCH 10/15] __d_add(): don't drop/regain ->d_lock

From Al Viro <viro@ZenIV.linux.org.uk>
Newsgroups linux.kernel
Subject Re: [PATCH 10/15] __d_add(): don't drop/regain ->d_lock
Date 2016-04-24 21:30 +0200
Message-ID <rrxTc-1ep-23@gated-at.bofh.it> (permalink)
References <romKB-3oC-3@gated-at.bofh.it> <romKC-3oC-5@gated-at.bofh.it> <rrwDL-oW-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sun, Apr 24, 2016 at 02:09:09PM -0400, Jeff Layton wrote:

> Should the above be a new __d_instantiate_locked instead of open-coding 
> it?

Nope - it gets rehash mashed into it a few commits later.  In principle
we could try to fish the common helper out of it and __d_instantiate()
once the dust settles, but IMO there's not much point.

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 10/15] __d_add(): don't drop/regain ->d_lock Al Viro <viro@ZenIV.linux.org.uk> - 2016-04-16 03:00 +0200
  Re: [PATCH 10/15] __d_add(): don't drop/regain ->d_lock Jeff Layton <jlayton@poochiereds.net> - 2016-04-24 20:10 +0200
    Re: [PATCH 10/15] __d_add(): don't drop/regain ->d_lock Al Viro <viro@ZenIV.linux.org.uk> - 2016-04-24 21:30 +0200

csiph-web