Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1378955

[PATCH 18/19] dax: move RADIX_DAX_ definitions to dax.c

From Matthew Wilcox <willy@linux.intel.com>
Newsgroups linux.kernel
Subject [PATCH 18/19] dax: move RADIX_DAX_ definitions to dax.c
Date 2016-04-14 16:40 +0200
Message-ID <rnQB6-33W-63@gated-at.bofh.it> (permalink)
References <rnQB5-33W-35@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: NeilBrown <neilb@suse.com>

These don't belong in radix-tree.h any more than PAGECACHE_TAG_* do.
Let's try to maintain the idea that radix-tree simply implements an
abstract data type.

Signed-off-by: NeilBrown <neilb@suse.com>
Reviewed-by: Ross Zwisler <ross.zwisler@linux.intel.com>
Reviewed-by: Jan Kara <jack@suse.cz>
Signed-off-by: Matthew Wilcox <willy@linux.intel.com>
---
 fs/dax.c                   | 9 +++++++++
 include/linux/radix-tree.h | 9 ---------
 2 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/fs/dax.c b/fs/dax.c
index 90322eb..735a608 100644
--- a/fs/dax.c
+++ b/fs/dax.c
@@ -32,6 +32,15 @@
 #include <linux/pfn_t.h>
 #include <linux/sizes.h>
 
+#define RADIX_DAX_MASK	0xf
+#define RADIX_DAX_SHIFT	4
+#define RADIX_DAX_PTE  (0x4 | RADIX_TREE_EXCEPTIONAL_ENTRY)
+#define RADIX_DAX_PMD  (0x8 | RADIX_TREE_EXCEPTIONAL_ENTRY)
+#define RADIX_DAX_TYPE(entry) ((unsigned long)entry & RADIX_DAX_MASK)
+#define RADIX_DAX_SECTOR(entry) (((unsigned long)entry >> RADIX_DAX_SHIFT))
+#define RADIX_DAX_ENTRY(sector, pmd) ((void *)((unsigned long)sector << \
+		RADIX_DAX_SHIFT | (pmd ? RADIX_DAX_PMD : RADIX_DAX_PTE)))
+
 static long dax_map_atomic(struct block_device *bdev, struct blk_dax_ctl *dax)
 {
 	struct request_queue *q = bdev->bd_queue;
diff --git a/include/linux/radix-tree.h b/include/linux/radix-tree.h
index 11c8e7c..c2f69e2 100644
--- a/include/linux/radix-tree.h
+++ b/include/linux/radix-tree.h
@@ -48,15 +48,6 @@
 #define RADIX_TREE_EXCEPTIONAL_ENTRY	2
 #define RADIX_TREE_EXCEPTIONAL_SHIFT	2
 
-#define RADIX_DAX_MASK	0xf
-#define RADIX_DAX_SHIFT	4
-#define RADIX_DAX_PTE  (0x4 | RADIX_TREE_EXCEPTIONAL_ENTRY)
-#define RADIX_DAX_PMD  (0x8 | RADIX_TREE_EXCEPTIONAL_ENTRY)
-#define RADIX_DAX_TYPE(entry) ((unsigned long)entry & RADIX_DAX_MASK)
-#define RADIX_DAX_SECTOR(entry) (((unsigned long)entry >> RADIX_DAX_SHIFT))
-#define RADIX_DAX_ENTRY(sector, pmd) ((void *)((unsigned long)sector << \
-		RADIX_DAX_SHIFT | (pmd ? RADIX_DAX_PMD : RADIX_DAX_PTE)))
-
 static inline int radix_tree_is_internal_node(void *ptr)
 {
 	return (int)((unsigned long)ptr & RADIX_TREE_INTERNAL_NODE);
-- 
2.8.0.rc3

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/19] Radix tree cleanups Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200
  [PATCH 12/19] radix-tree: Change naming conventions in radix_tree_shrink Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200
  [PATCH 16/19] radix-tree: Introduce radix_tree_replace_clear_tags() Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200
  [PATCH 17/19] radix-tree: Make radix_tree_descend() more useful Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200
  [PATCH 01/19] drivers/hwspinlock: Use correct radix tree API Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200
  [PATCH 05/19] radix-tree: Remove a use of root->height from delete_node Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200
  [PATCH 18/19] dax: move RADIX_DAX_ definitions to dax.c Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200
  [PATCH 11/19] radix-tree: Rename radix_tree_is_indirect_ptr() Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
  [PATCH 06/19] radix tree test suite: Remove dependencies on height Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
  [PATCH 02/19] radix-tree: Miscellaneous fixes Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
  [PATCH 04/19] radix-tree: Replace node->height with node->shift Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
  [PATCH 10/19] radix-tree: Rename indirect_to_ptr() to entry_to_node() Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
  [PATCH 13/19] radix-tree: Tidy up next_chunk Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
  [PATCH 14/19] radix-tree: Tidy up range_tag_if_tagged Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
  [PATCH 15/19] radix-tree: Tidy up __radix_tree_create() Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
  [PATCH 08/19] radix-tree: Rename INDIRECT_PTR to INTERNAL_NODE Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
  [PATCH 03/19] radix-tree: Split node->path into offset and height Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
  [PATCH 09/19] radix-tree: Rename ptr_to_indirect() to node_to_entry() Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200

csiph-web