Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1378953
| From | Matthew Wilcox <willy@linux.intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 01/19] drivers/hwspinlock: Use correct radix tree API |
| Date | 2016-04-14 16:40 +0200 |
| Message-ID | <rnQB6-33W-61@gated-at.bofh.it> (permalink) |
| References | <rnQB5-33W-35@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
radix_tree_is_indirect_ptr() is an internal API. The correct call to use
is radix_tree_deref_retry() which has the appropriate unlikely() annotation.
Fixes: c6400ba7e13a ("drivers/hwspinlock: fix race between radix tree insertion and lookup")
Signed-off-by: Matthew Wilcox <willy@linux.intel.com>
---
drivers/hwspinlock/hwspinlock_core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/hwspinlock/hwspinlock_core.c b/drivers/hwspinlock/hwspinlock_core.c
index d50c701..4074441 100644
--- a/drivers/hwspinlock/hwspinlock_core.c
+++ b/drivers/hwspinlock/hwspinlock_core.c
@@ -313,7 +313,7 @@ int of_hwspin_lock_get_id(struct device_node *np, int index)
hwlock = radix_tree_deref_slot(slot);
if (unlikely(!hwlock))
continue;
- if (radix_tree_is_indirect_ptr(hwlock)) {
+ if (radix_tree_deref_retry(hwlock)) {
slot = radix_tree_iter_retry(&iter);
continue;
}
--
2.8.0.rc3
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/19] Radix tree cleanups Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200 [PATCH 12/19] radix-tree: Change naming conventions in radix_tree_shrink Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200 [PATCH 16/19] radix-tree: Introduce radix_tree_replace_clear_tags() Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200 [PATCH 17/19] radix-tree: Make radix_tree_descend() more useful Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200 [PATCH 01/19] drivers/hwspinlock: Use correct radix tree API Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200 [PATCH 05/19] radix-tree: Remove a use of root->height from delete_node Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200 [PATCH 18/19] dax: move RADIX_DAX_ definitions to dax.c Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:40 +0200 [PATCH 11/19] radix-tree: Rename radix_tree_is_indirect_ptr() Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200 [PATCH 06/19] radix tree test suite: Remove dependencies on height Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200 [PATCH 02/19] radix-tree: Miscellaneous fixes Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200 [PATCH 04/19] radix-tree: Replace node->height with node->shift Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200 [PATCH 10/19] radix-tree: Rename indirect_to_ptr() to entry_to_node() Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200 [PATCH 13/19] radix-tree: Tidy up next_chunk Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200 [PATCH 14/19] radix-tree: Tidy up range_tag_if_tagged Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200 [PATCH 15/19] radix-tree: Tidy up __radix_tree_create() Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200 [PATCH 08/19] radix-tree: Rename INDIRECT_PTR to INTERNAL_NODE Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200 [PATCH 03/19] radix-tree: Split node->path into offset and height Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200 [PATCH 09/19] radix-tree: Rename ptr_to_indirect() to node_to_entry() Matthew Wilcox <willy@linux.intel.com> - 2016-04-14 16:50 +0200
csiph-web