Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1360172
| From | Joe Perches <joe@perches.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() |
| Date | 2016-03-17 21:30 +0100 |
| Message-ID | <rdMIr-3Gi-15@gated-at.bofh.it> (permalink) |
| References | <rdK3U-1W6-9@gated-at.bofh.it> <rdK3U-1W6-13@gated-at.bofh.it> <rdKdA-1Zz-15@gated-at.bofh.it> <rdKwX-2ml-15@gated-at.bofh.it> <rdL9E-2zN-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, 2016-03-17 at 15:43 -0300, Gustavo Padovan wrote: > 2016-03-17 Gustavo Padovan <gustavo.padovan@collabora.co.uk>: > > 2016-03-17 Joe Perches <joe@perches.com>: > > > On Thu, 2016-03-17 at 14:30 -0300, Gustavo Padovan wrote: > > > > > > > > This function had copies in 3 different files. Unify them in > > > > kernel.h. > > > This is only used by gpu/drm. > > > > > > I think this is a poor name for a generic function > > > that would be in kernel.h. > > > > > > Isn't there an include file in linux/drm that's > > > appropriate for this. Maybe drmP.h > > > > > > Maybe prefix this function name with drm_ too. > > No, the next patch adds a user to drivers/staging (which will be moved > > to drivers/dma-buf) soon. Maybe move to a different header in > > include/linux/? not sure which one. > > > > > > > > Also, there's this that might conflict: > > > > > > arch/powerpc/kernel/signal_32.c:#define to_user_ptr(p) ptr_to_compat(p) > > > arch/powerpc/kernel/signal_32.c:#define to_user_ptr(p) ((unsigned long)(p)) > > Right, I'll figure out how to replace these two too. > The powerpc to_user_ptr has a different meaning from the one I'm adding > in this patch. I propose we just rename powerpc's to_user_ptr to > __to_user_ptr and leave the rest as is. I think that's not a good idea, and you should really check this concept with the powerpc folk (added to to:s and cc:ed) If it were really added, then the function meaning is incorrect. This is taking a u64, casting that to (unsigned long/uint_ptr_t), then converting that to a user pointer. Does that naming and use make sense on x86-32 or arm32?
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v9 1/3] staging/android: remove redundant comments on sync_merge_data Gustavo Padovan <gustavo@padovan.org> - 2016-03-17 18:40 +0100
[PATCH v9 2/3] kernel.h: add to_user_ptr() Gustavo Padovan <gustavo@padovan.org> - 2016-03-17 18:40 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Joe Perches <joe@perches.com> - 2016-03-17 18:50 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Gustavo Padovan <gustavo.padovan@collabora.co.uk> - 2016-03-17 19:10 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Gustavo Padovan <gustavo@padovan.org> - 2016-03-17 19:50 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Joe Perches <joe@perches.com> - 2016-03-17 21:30 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Rob Clark <robdclark@gmail.com> - 2016-03-17 21:40 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Joe Perches <joe@perches.com> - 2016-03-17 21:50 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Rob Clark <robdclark@gmail.com> - 2016-03-17 22:00 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Joe Perches <joe@perches.com> - 2016-03-17 22:20 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Gustavo Padovan <gustavo@padovan.org> - 2016-03-17 22:20 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Rob Clark <robdclark@gmail.com> - 2016-03-17 22:30 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Joe Perches <joe@perches.com> - 2016-03-17 22:40 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Gustavo Padovan <gustavo@padovan.org> - 2016-03-17 23:20 +0100
Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() Daniel Vetter <daniel@ffwll.ch> - 2016-03-18 09:30 +0100
[PATCH v9 3/3] staging/android: refactor SYNC IOCTLs Gustavo Padovan <gustavo@padovan.org> - 2016-03-17 18:40 +0100
csiph-web