Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1360017

Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU attached devices

From Sinan Kaya <okaya@codeaurora.org>
Newsgroups linux.kernel
Subject Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU attached devices
Date 2016-03-17 17:40 +0100
Message-ID <rdJ7R-1lp-19@gated-at.bofh.it> (permalink)
References <rdIv7-Qo-7@gated-at.bofh.it> <rdIv7-Qo-5@gated-at.bofh.it> <rdIEP-1aN-47@gated-at.bofh.it> <rdIOt-1e4-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 3/17/2016 12:14 PM, Arnd Bergmann wrote:
> On Thursday 17 March 2016 12:07:26 Sinan Kaya wrote:
>> On 3/17/2016 11:57 AM, Robin Murphy wrote:
>>
>> Let me know which direction I should go. 
>>
>> 1. Fix phys_to_dma and keep dma_to_phys as in the patch.
>> 2. Remove both of the API from header file, move it to where it is needed. Rename them as swio_phys_to_dma etc.
> 
> Use 2.
> 
> It has been a long way to remove all virt_to_bus/bus_to_virt users
> from the common architectures, we are not putting them back under
> a different name.
> 
> Drivers already know the physical address because that is what they
> put into dma_map_*() in the first place.
> 
> 	Arnd
> 

The first solution that comes to my mind is to implement a weak function in
swiotlb.c with these contents

dma_addr_t __weak swio_phys_to_dma(struct device *dev, phys_addr_t paddr)
{
        return paddr;
}

 
phys_addr_t __weak  swio_dma_to_phys(struct device *dev, dma_addr_t daddr)
{
        return daddr;
}

then clean up all the duplicates in dma-mapping.h for all ARCHs that have
identical code. 

For others move the implementation to some source file.


-- 
Sinan Kaya
Qualcomm Technologies, Inc. on behalf of Qualcomm Innovation Center, Inc.
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum, a Linux Foundation Collaborative Project

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU  attached devices Robin Murphy <robin.murphy@arm.com> - 2016-03-17 17:00 +0100
  Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU  attached devices Sinan Kaya <okaya@codeaurora.org> - 2016-03-17 17:10 +0100
    Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU attached devices Arnd Bergmann <arnd@arndb.de> - 2016-03-17 17:20 +0100
      Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU  attached devices Sinan Kaya <okaya@codeaurora.org> - 2016-03-17 17:40 +0100
        Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU attached devices Arnd Bergmann <arnd@arndb.de> - 2016-03-17 18:10 +0100

csiph-web