Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1359988

Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU attached devices

From Sinan Kaya <okaya@codeaurora.org>
Newsgroups linux.kernel
Subject Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU attached devices
Date 2016-03-17 17:10 +0100
Message-ID <rdIEP-1aN-47@gated-at.bofh.it> (permalink)
References <rdIv7-Qo-7@gated-at.bofh.it> <rdIv7-Qo-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 3/17/2016 11:57 AM, Robin Murphy wrote:
>> This patch modifies dma_to_phys to call iommu_iova_to_phys to perform dma
>> to phys conversions for IOMMU attached devices where dma and physical
>> addresses often have distinct values.
> 
> What's this for? dma_to_phys() is only used by SWIOTLB, and that's mutually exclusive with IOMMU ops.

If it is SWIOTLB only, then it needs to disappear from common header file as 
it is doing the wrong thing when IOMMU is enabled for a device. 

I have some device driver (HIDMA) that used dma_to_phys during DMA self test.
I needed this patch to get it working properly. I removed the self test from
my code but I still don't feel right about this dma_to_phys API returning physical
addresses.

> 
> Also, what about phys_to_dma()?

Agreed, need to fix phys_to_dma too.

> 
> Robin.

Let me know which direction I should go. 

1. Fix phys_to_dma and keep dma_to_phys as in the patch.
2. Remove both of the API from header file, move it to where it is needed. Rename them as swio_phys_to_dma etc.

-- 
Sinan Kaya
Qualcomm Technologies, Inc. on behalf of Qualcomm Innovation Center, Inc.
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum, a Linux Foundation Collaborative Project

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU  attached devices Robin Murphy <robin.murphy@arm.com> - 2016-03-17 17:00 +0100
  Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU  attached devices Sinan Kaya <okaya@codeaurora.org> - 2016-03-17 17:10 +0100
    Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU attached devices Arnd Bergmann <arnd@arndb.de> - 2016-03-17 17:20 +0100
      Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU  attached devices Sinan Kaya <okaya@codeaurora.org> - 2016-03-17 17:40 +0100
        Re: [PATCH] arm64: dma-mapping: fix dma_to_phys API for IOMMU attached devices Arnd Bergmann <arnd@arndb.de> - 2016-03-17 18:10 +0100

csiph-web