Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1448697
| From | Sean Paul <seanpaul@chromium.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/4] GPU-DRM-Etnaviv: Delete unnecessary checks before two function calls |
| Date | 2016-07-22 20:00 +0200 |
| Message-ID | <rXMTU-xT-35@gated-at.bofh.it> (permalink) |
| References | (14 earlier) <mSsDN-4wa-63@gated-at.bofh.it> <mSsDN-4wa-65@gated-at.bofh.it> <mSsDN-4wa-33@gated-at.bofh.it> <rXKS5-7EN-3@gated-at.bofh.it> <rXKS6-7EN-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, Jul 22, 2016 at 11:47 AM, SF Markus Elfring
<elfring@users.sourceforge.net> wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Fri, 22 Jul 2016 15:56:15 +0200
>
> The functions drm_gem_object_unreference_unlocked() and vunmap() perform
> also input parameter validation.
> Thus the tests around their calls are not needed.
>
> This issue was detected by using the Coccinelle software.
>
> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
Applied to drm-misc. In the future, could you please format your
subjects starting with "drm/<driver>"? I've fixed this one and the
next, but it'd be nice not to have to do that going forward.
> ---
> drivers/gpu/drm/etnaviv/etnaviv_gem.c | 7 ++-----
> 1 file changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/gpu/drm/etnaviv/etnaviv_gem.c b/drivers/gpu/drm/etnaviv/etnaviv_gem.c
> index 8c6f750..8eee742 100644
> --- a/drivers/gpu/drm/etnaviv/etnaviv_gem.c
> +++ b/drivers/gpu/drm/etnaviv/etnaviv_gem.c
> @@ -535,8 +535,7 @@ void etnaviv_gem_describe_objects(struct etnaviv_drm_private *priv,
>
> static void etnaviv_gem_shmem_release(struct etnaviv_gem_object *etnaviv_obj)
> {
> - if (etnaviv_obj->vaddr)
> - vunmap(etnaviv_obj->vaddr);
> + vunmap(etnaviv_obj->vaddr);
> put_pages(etnaviv_obj);
> }
>
> @@ -670,9 +669,7 @@ static struct drm_gem_object *__etnaviv_gem_new(struct drm_device *dev,
> return obj;
>
> fail:
> - if (obj)
> - drm_gem_object_unreference_unlocked(obj);
> -
> + drm_gem_object_unreference_unlocked(obj);
> return ERR_PTR(ret);
> }
>
> --
> 2.9.2
>
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/4] GPU-DRM-Etnaviv: Fine-tuning for a few functions SF Markus Elfring <elfring@users.sourceforge.net> - 2016-07-22 17:50 +0200
[PATCH 2/4] GPU-DRM-Etnaviv: Delete unnecessary if statement in __etnaviv_gem_new() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-07-22 17:50 +0200
Re: [PATCH 2/4] GPU-DRM-Etnaviv: Delete unnecessary if statement in __etnaviv_gem_new() walter harms <wharms@bfs.de> - 2016-07-22 18:50 +0200
[PATCH] drm/etnaviv: Improve readability in __etnaviv_gem_new Sean Paul <seanpaul@chromium.org> - 2016-07-22 19:50 +0200
[PATCH 1/4] GPU-DRM-Etnaviv: Delete unnecessary checks before two function calls SF Markus Elfring <elfring@users.sourceforge.net> - 2016-07-22 17:50 +0200
Re: [PATCH 1/4] GPU-DRM-Etnaviv: Delete unnecessary checks before two function calls Sean Paul <seanpaul@chromium.org> - 2016-07-22 20:00 +0200
[PATCH 4/4] GPU-DRM-Etnaviv: Optimize error handling in etnaviv_gem_new_userptr() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-07-22 18:00 +0200
Re: [PATCH 4/4] GPU-DRM-Etnaviv: Optimize error handling in etnaviv_gem_new_userptr() Sean Paul <seanpaul@chromium.org> - 2016-07-22 20:00 +0200
[PATCH 3/4] GPU-DRM-Etnaviv: Rename jump labels SF Markus Elfring <elfring@users.sourceforge.net> - 2016-07-22 18:00 +0200
Re: [PATCH 3/4] GPU-DRM-Etnaviv: Rename jump labels Sean Paul <seanpaul@chromium.org> - 2016-07-22 19:50 +0200
csiph-web