Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1448691

Re: [PATCH 3/4] GPU-DRM-Etnaviv: Rename jump labels

From Sean Paul <seanpaul@chromium.org>
Newsgroups linux.kernel
Subject Re: [PATCH 3/4] GPU-DRM-Etnaviv: Rename jump labels
Date 2016-07-22 19:50 +0200
Message-ID <rXMKe-r1-21@gated-at.bofh.it> (permalink)
References (14 earlier) <mSsDN-4wa-63@gated-at.bofh.it> <mSsDN-4wa-65@gated-at.bofh.it> <mSsDN-4wa-33@gated-at.bofh.it> <rXKS5-7EN-3@gated-at.bofh.it> <rXL1M-7Ib-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Jul 22, 2016 at 11:50 AM, SF Markus Elfring
<elfring@users.sourceforge.net> wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Fri, 22 Jul 2016 16:51:00 +0200
>
> Adjust jump targets according to the Linux coding style convention.
>

I'm not convinced the old labels are really that bad, tbh.

Sean

> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
> ---
>  drivers/gpu/drm/etnaviv/etnaviv_gem.c | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/gpu/drm/etnaviv/etnaviv_gem.c b/drivers/gpu/drm/etnaviv/etnaviv_gem.c
> index 851a8ba..0a5c00c 100644
> --- a/drivers/gpu/drm/etnaviv/etnaviv_gem.c
> +++ b/drivers/gpu/drm/etnaviv/etnaviv_gem.c
> @@ -308,17 +308,17 @@ struct etnaviv_vram_mapping *etnaviv_gem_mapping_get(
>                                 mapping = NULL;
>                         mutex_unlock(&gpu->mmu->lock);
>                         if (mapping)
> -                               goto out;
> +                               goto unlock;
>                 } else {
>                         mapping->use += 1;
> -                       goto out;
> +                       goto unlock;
>                 }
>         }
>
>         pages = etnaviv_gem_get_pages(etnaviv_obj);
>         if (IS_ERR(pages)) {
>                 ret = PTR_ERR(pages);
> -               goto out;
> +               goto unlock;
>         }
>
>         /*
> @@ -330,7 +330,7 @@ struct etnaviv_vram_mapping *etnaviv_gem_mapping_get(
>                 mapping = kzalloc(sizeof(*mapping), GFP_KERNEL);
>                 if (!mapping) {
>                         ret = -ENOMEM;
> -                       goto out;
> +                       goto unlock;
>                 }
>
>                 INIT_LIST_HEAD(&mapping->scan_node);
> @@ -349,7 +349,7 @@ struct etnaviv_vram_mapping *etnaviv_gem_mapping_get(
>         else
>                 list_add_tail(&mapping->obj_node, &etnaviv_obj->vram_list);
>
> -out:
> +unlock:
>         mutex_unlock(&etnaviv_obj->lock);
>
>         if (ret)
> @@ -646,7 +646,7 @@ static struct drm_gem_object *__etnaviv_gem_new(struct drm_device *dev,
>         ret = etnaviv_gem_new_impl(dev, size, flags, NULL,
>                                    &etnaviv_gem_shmem_ops, &obj);
>         if (ret)
> -               goto fail;
> +               goto unreference;
>
>         ret = drm_gem_object_init(dev, obj, size);
>         if (ret == 0) {
> @@ -664,7 +664,7 @@ static struct drm_gem_object *__etnaviv_gem_new(struct drm_device *dev,
>                 return obj;
>         }
>
> -fail:
> +unreference:
>         drm_gem_object_unreference_unlocked(obj);
>         return ERR_PTR(ret);
>  }
> --
> 2.9.2
>
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 0/4] GPU-DRM-Etnaviv: Fine-tuning for a few functions SF Markus Elfring <elfring@users.sourceforge.net> - 2016-07-22 17:50 +0200
  [PATCH 2/4] GPU-DRM-Etnaviv: Delete unnecessary if statement in  __etnaviv_gem_new() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-07-22 17:50 +0200
    Re: [PATCH 2/4] GPU-DRM-Etnaviv: Delete unnecessary if statement  in __etnaviv_gem_new() walter harms <wharms@bfs.de> - 2016-07-22 18:50 +0200
      [PATCH] drm/etnaviv: Improve readability in __etnaviv_gem_new Sean Paul <seanpaul@chromium.org> - 2016-07-22 19:50 +0200
  [PATCH 1/4] GPU-DRM-Etnaviv: Delete unnecessary checks before two  function calls SF Markus Elfring <elfring@users.sourceforge.net> - 2016-07-22 17:50 +0200
    Re: [PATCH 1/4] GPU-DRM-Etnaviv: Delete unnecessary checks before two  function calls Sean Paul <seanpaul@chromium.org> - 2016-07-22 20:00 +0200
  [PATCH 4/4] GPU-DRM-Etnaviv: Optimize error handling in  etnaviv_gem_new_userptr() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-07-22 18:00 +0200
    Re: [PATCH 4/4] GPU-DRM-Etnaviv: Optimize error handling in etnaviv_gem_new_userptr() Sean Paul <seanpaul@chromium.org> - 2016-07-22 20:00 +0200
  [PATCH 3/4] GPU-DRM-Etnaviv: Rename jump labels SF Markus Elfring <elfring@users.sourceforge.net> - 2016-07-22 18:00 +0200
    Re: [PATCH 3/4] GPU-DRM-Etnaviv: Rename jump labels Sean Paul <seanpaul@chromium.org> - 2016-07-22 19:50 +0200

csiph-web