Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1442493
| From | Jiri Olsa <jolsa@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v15 09/12] perf record: Read from overwritable ring buffer |
| Date | 2016-07-13 16:10 +0200 |
| Message-ID | <rUt1o-47M-13@gated-at.bofh.it> (permalink) |
| References | <rU2NA-3tA-5@gated-at.bofh.it> <rU2NB-3tA-47@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Jul 12, 2016 at 10:00:09AM +0000, Wang Nan wrote:
SNIP
> + * (1): Pause ring buffers for reading
> + * (2): Read from ring buffers
> + * (3): Resume ring buffers for recording
> + */
> +enum overwrite_evt_state {
> + OVERWRITE_EVT_RUNNING,
> + OVERWRITE_EVT_DATA_PENDING,
> + OVERWRITE_EVT_EMPTY,
> +};
>
> struct record {
> struct perf_tool tool;
> @@ -61,6 +85,7 @@ struct record {
> bool buildid_all;
> bool timestamp_filename;
> bool switch_output;
> + enum overwrite_evt_state overwrite_evt_state;
> unsigned long long samples;
I wonder this would be better to have in 'struct evlist',
also 'enum owr_mmap_state' might be better name then
thanks,
jirka
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v15 09/12] perf record: Read from overwritable ring buffer Wang Nan <wangnan0@huawei.com> - 2016-07-12 12:10 +0200 Re: [PATCH v15 09/12] perf record: Read from overwritable ring buffer Jiri Olsa <jolsa@redhat.com> - 2016-07-13 16:10 +0200 Re: [PATCH v15 09/12] perf record: Read from overwritable ring buffer Jiri Olsa <jolsa@redhat.com> - 2016-07-13 16:10 +0200 Re: [PATCH v15 09/12] perf record: Read from overwritable ring buffer Jiri Olsa <jolsa@redhat.com> - 2016-07-13 16:10 +0200
csiph-web