Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1443722

Re: [PATCH] security: Use IS_ENABLED() instead of checking for built-in or module

From Paul Moore <paul@paul-moore.com>
Newsgroups linux.kernel
Subject Re: [PATCH] security: Use IS_ENABLED() instead of checking for built-in or module
Date 2016-07-14 22:00 +0200
Message-ID <rUUXD-5t8-1@gated-at.bofh.it> (permalink)
References <rURn4-3qz-9@gated-at.bofh.it> <rURwJ-3tZ-5@gated-at.bofh.it> <rURGp-3xe-3@gated-at.bofh.it> <rURQ6-3AM-27@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, Jul 14, 2016 at 12:30 PM, Casey Schaufler
<casey@schaufler-ca.com> wrote:
> On 7/14/2016 9:20 AM, Javier Martinez Canillas wrote:
>> Hello Casey,
>>
>> On 07/14/2016 12:17 PM, Casey Schaufler wrote:
>>> On 7/14/2016 9:00 AM, Javier Martinez Canillas wrote:
>>>> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
>>>> built-in or as a module, use that macro instead of open coding the same.
>>> Why?
>>
>> Why not? We have a macro for this so why is better to open coding it?
>
> Unless there is a real advantage to IS_ENABLED() over ifdef there
> is no value in making the change. Any change can introduce a problem,
> so we don't make changes based on "why not". It's called code churn.

I think the IS_ENABLED() macro makes the code more readable by helping
abstract away some of the Kconfig/module details; not to mention it
provides some insulation from Kconfig changes (although I suppose it
is doubtful this will be a real issue anytime soon).

Javier, if you want to respin this patch without the Smack changes
I'll merge it into the SELinux tree (not for the v4.8 merge window,
but for the next merge window).  However, if Casey changes his mind
and ACKs this patch, I'll go ahead and merge the original patch.

-- 
paul moore
www.paul-moore.com

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] security: Use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-07-14 18:10 +0200
  Re: [PATCH] security: Use IS_ENABLED() instead of checking for  built-in or module Casey Schaufler <casey@schaufler-ca.com> - 2016-07-14 18:20 +0200
    Re: [PATCH] security: Use IS_ENABLED() instead of checking for  built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-07-14 18:30 +0200
      Re: [PATCH] security: Use IS_ENABLED() instead of checking for  built-in or module Casey Schaufler <casey@schaufler-ca.com> - 2016-07-14 18:40 +0200
        Re: [PATCH] security: Use IS_ENABLED() instead of checking for  built-in or module Paul Moore <paul@paul-moore.com> - 2016-07-14 22:00 +0200
          Re: [PATCH] security: Use IS_ENABLED() instead of checking for  built-in or module Casey Schaufler <casey@schaufler-ca.com> - 2016-07-14 23:00 +0200
            Re: [PATCH] security: Use IS_ENABLED() instead of checking for  built-in or module Paul Moore <paul@paul-moore.com> - 2016-07-15 00:10 +0200
              Re: [PATCH] security: Use IS_ENABLED() instead of checking for  built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-07-15 13:40 +0200

csiph-web