Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1440006

Re: [PATCH] mtd: Replace if and BUG with BUG_ON

From Brian Norris <computersforpeace@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH] mtd: Replace if and BUG with BUG_ON
Date 2016-07-10 04:00 +0200
Message-ID <rTcch-2h0-7@gated-at.bofh.it> (permalink)
References <rDPAZ-2Qo-1@gated-at.bofh.it> <rEDHr-1Vq-9@gated-at.bofh.it> <rEKIV-6JU-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi,

On Tue, May 31, 2016 at 07:41:23AM +0200, Julia Lawall wrote:
> On Mon, 30 May 2016, Ezequiel Garcia wrote:
> > On 28 May 2016 at 13:41, Amitoj Kaur Chawla <amitoj1606@gmail.com> wrote:
> > > Replace if condition and BUG() with a BUG_ON having the conditional
> > > expression of the if statement as argument.
[...]

> > > diff --git a/drivers/mtd/ssfdc.c b/drivers/mtd/ssfdc.c
> > > index daf82ba..41b13d1 100644
> > > --- a/drivers/mtd/ssfdc.c
> > > +++ b/drivers/mtd/ssfdc.c
> > > @@ -380,8 +380,7 @@ static int ssfdcr_readsect(struct mtd_blktrans_dev *dev,
> > >                 " block_addr=%d\n", logic_sect_no, sectors_per_block, offset,
> > >                 block_address);
> > >
> > > -       if (block_address >= ssfdc->map_len)
> > > -               BUG();
> > > +       BUG_ON(block_address >= ssfdc->map_len);
> > >
> > 
> > I don't want to be rude, but I wonder if there's any value at all in
> > such a patch. It barely improves readability, it barely reduces the
> > LoC, yet it consumes developer time, maintainer time, and changes git
> > per-line authorship (used in git blame).
> 
> Actually, I think that this particular patch does improve readability a 
> bit.  Scanning straight down the code is easier than looking under an if.
> Also, git blame now has a way to go back in history (although I don't 
> remember what it is), so the argument that cleaning up the code makes it 
> very difficult to find why the nontrivial part of the code is as it is 
> doesn't completely hold any more.

I agree it's a small improvement. Not sure I'd worry too much about
git-blame. Applied to l2-mtd.git.

Brian

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH] mtd: Replace if and BUG with BUG_ON Brian Norris <computersforpeace@gmail.com> - 2016-07-10 04:00 +0200

csiph-web