Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1434248
| From | Yakir Yang <ykk@rock-chips.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v4 0/11] Misc fixup and add RK3399 eDP support to Analogix DP driver[Involving remittance information, please pay attention to the safety of property] |
| Date | 2016-06-30 08:40 +0200 |
| Message-ID | <rPDNM-6av-9@gated-at.bofh.it> (permalink) |
| References | <rPjP3-2kI-7@gated-at.bofh.it> <rPoOK-5l8-35@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Sean, On 06/29/2016 10:01 PM, Sean Paul wrote: > On Wed, Jun 29, 2016 at 5:14 AM, Yakir Yang <ykk@rock-chips.com> wrote: >> RK3399 and RK3288 shared the same eDP IP controller, only some light >> difference with VOP configure and GRF configure. >> > The whole set looks good to me. All patches should have my R-b now, > thanks for the update. Thanks :-D - Yakir > Sean > > > >> Also same misc fix to analogix_dp driver: >> - Hotplug invalid which report by Dan Carpenter >> - Make panel detect to an optional action >> - correct the register bit define error in ANALOGIX_DP_PLL_REG_1 >> >> Changes in v4: >> - Assigned the GRF setting magic numbers to a #define that corresponds to >> a TRM name. (Sean & Heiko) >> - Pass the chip type to device type directly. (Sean) >> - Add reviewed flag from Tomasz. >> - Add reviewed flag from Sean >> - Remove subdev_type number, and add 'is_rockchip(type)' helper function (Sean) >> - Add reviewed flag from Tomasz. >> - Improved the overly complicated .atomic_check function. (Sean) >> - Add reviewed flag from Tomasz >> - Move of_node_put(panel_node) directly below of_drm_find_panel (Sean) >> - Add reviewed flag from Tomasz >> - Add reviewed flag from Sean. >> - Add reviewed flag from Tomasz. >> - Using mask variable to collect the YUV video format. (Sean) >> - Add reviewed flag from Tomasz. >> - Correct the misspell of 'contoller'. (Sean) >> - Add reviewed flag from Sean. >> - Add reviewed flag from Tomasz. >> - Add reviewed flag from Doug. >> - Add reviewed flag from Tomasz. >> - Fix compiled error, sorry. >> "dp->cgfclk" --> 'dp->grfclk' >> - Check the the error code properly, 'EPROBE_DEFER' should be returned, >> 'ENOENT' should assign a NULL point to grfclk, other errors should be >> regarded as failed. (Tomasz, Doug, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/351821/20/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c@249] >> - Add the document about optional 'grf' clock (Tomasz, Doug, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/351821/] >> - Add reviewed flag from Doug. >> - Add reviewed flag from Tomasz. >> >> Changes in v3: >> - Write a kerneldoc-style comment explaining the chips data fields (Tomasz, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346313/10/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c@39] >> - Drop the '.lcdcsel_mask' number in chips data field (Tomasz, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346313/10/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c@382] >> - Add acked flag from Mark. >> - Add reviewed flag from Tomasz. >> [https://chromium-review.googlesource.com/#/c/346315/15] >> - Add tested flag from Javier >> - Make this hack code more clear (Tomasz, reviewed at Google Gerrit) >> reg = ~reg & REF_CLK_MASK; ---> reg ^= REF_CLK_MASK; >> [https://chromium-review.googlesource.com/#/c/346852/7/drivers/gpu/drm/bridge/analogix/analogix_dp_reg.c@80] >> - Add tested flag from Javier >> - Give the "rk3399-edp" a separate line for clarity in document (Tomasz, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346314/10/Documentation/devicetree/bindings/display/rockchip/analogix_dp-rockchip.txt@5] >> - Move 'output_type' setting before the return statement (Tomasz, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346314/10/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c@154] >> - Add the acked flag from Mark. >> - Add the acked flag from Mark. >> - Avoid to change any internal driver state in .mode_valid interface. (Tomasz, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346318/10/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c@113] >> - Hook the connector's color_formats in .get_modes directly. (Tomasz, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346317/15] >> - Add the acked flag from Mark. >> - Add the reviewed flag from Tomasz. >> [https://chromium-review.googlesource.com/#/c/346853/12] >> - Add the acked flag from Mark. >> - Add reviewed flag from Stéphane. >> [https://chromium-review.googlesource.com/#/c/346319/15] >> - Add tested flag from Javier >> - Add this patch in v3 >> - Add this patch in v3 >> >> Yakir Yang (11): >> drm/rockchip: analogix_dp: split the lcdc select setting into device >> data >> drm/bridge: analogix_dp: correct the register bit define error in >> ANALOGIX_DP_PLL_REG_1 >> drm/bridge: analogix_dp: some rockchip chips need to flip REF_CLK bit >> setting >> drm/rockchip: analogix_dp: add rk3399 eDP support >> drm/rockchip: analogix_dp: make panel detect to an optional action >> drm/bridge: analogix_dp: passing the connector as an argument in >> .get_modes() >> drm/rockchip: analogix_dp: correct the connector display color format >> and bpc >> drm/rockchip: analogix_dp: update the comments about why need to >> hardcode VOP output mode >> drm/bridge: analogix_dp: fix no drm hpd event when panel plug in >> drm/rockchip: analogix_dp: introduce the pclk for grf >> dt-bindings: analogix_dp: rockchip: correct the wrong compatible name >> >> .../bindings/display/bridge/analogix_dp.txt | 1 + >> .../display/rockchip/analogix_dp-rockchip.txt | 9 +- >> drivers/gpu/drm/bridge/analogix/analogix_dp_core.c | 2 +- >> drivers/gpu/drm/bridge/analogix/analogix_dp_core.h | 8 +- >> drivers/gpu/drm/bridge/analogix/analogix_dp_reg.c | 12 +- >> drivers/gpu/drm/bridge/analogix/analogix_dp_reg.h | 5 +- >> drivers/gpu/drm/exynos/exynos_dp.c | 4 +- >> drivers/gpu/drm/rockchip/analogix_dp-rockchip.c | 174 +++++++++++++++------ >> include/drm/bridge/analogix_dp.h | 9 +- >> 9 files changed, 160 insertions(+), 64 deletions(-) >> >> -- >> 1.9.1 >> >> >> -- >> To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in >> the body of a message to majordomo@vger.kernel.org >> More majordomo info at http://vger.kernel.org/majordomo-info.html > >
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v4 0/11] Misc fixup and add RK3399 eDP support to Analogix DP driver Yakir Yang <ykk@rock-chips.com> - 2016-06-29 11:20 +0200
[PATCH v4 10/11] drm/rockchip: analogix_dp: introduce the pclk for grf Yakir Yang <ykk@rock-chips.com> - 2016-06-29 11:20 +0200
[PATCH v4 11/11] dt-bindings: analogix_dp: rockchip: correct the wrong compatible name Yakir Yang <ykk@rock-chips.com> - 2016-06-29 11:20 +0200
[PATCH v4 09/11] drm/bridge: analogix_dp: fix no drm hpd event when panel plug in Yakir Yang <ykk@rock-chips.com> - 2016-06-29 11:20 +0200
[PATCH v4 05/11] drm/rockchip: analogix_dp: make panel detect to an optional action Yakir Yang <ykk@rock-chips.com> - 2016-06-29 11:20 +0200
[PATCH v4 04/11] drm/rockchip: analogix_dp: add rk3399 eDP support Yakir Yang <ykk@rock-chips.com> - 2016-06-29 11:30 +0200
[PATCH v4 08/11] drm/rockchip: analogix_dp: update the comments about why need to hardcode VOP output mode Yakir Yang <ykk@rock-chips.com> - 2016-06-29 11:30 +0200
Re: [PATCH v4 08/11] drm/rockchip: analogix_dp: update the comments about why need to hardcode VOP output mode Sean Paul <seanpaul@chromium.org> - 2016-06-29 16:00 +0200
[PATCH v4 03/11] drm/bridge: analogix_dp: some rockchip chips need to flip REF_CLK bit setting Yakir Yang <ykk@rock-chips.com> - 2016-06-29 11:30 +0200
Re: [PATCH v4 0/11] Misc fixup and add RK3399 eDP support to Analogix DP driver Sean Paul <seanpaul@chromium.org> - 2016-06-29 16:40 +0200
Re: [PATCH v4 0/11] Misc fixup and add RK3399 eDP support to Analogix DP driver[Involving remittance information, please pay attention to the safety of property] Yakir Yang <ykk@rock-chips.com> - 2016-06-30 08:40 +0200
csiph-web