Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1431944
| From | Joe Perches <joe@perches.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/7] efi: Document #define FOO_PROTOCOL_GUID layout |
| Date | 2016-06-27 13:20 +0200 |
| Message-ID | <rOCK6-7WH-15@gated-at.bofh.it> (permalink) |
| References | <rNQcp-2yr-5@gated-at.bofh.it> <rNQcq-2yr-15@gated-at.bofh.it> <rOCh4-7wA-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, 2016-06-27 at 12:49 +0200, Ingo Molnar wrote:
> * Matt Fleming <matt@codeblueprint.co.uk> wrote:
[]
> > + * EFI Configuration Table and GUID definitions
> > + *
> > + * These should be formatted roughly like the ones in the UEFI SPEC has
> > + * them. It makes them easier to grep for, and they look the same when
> > + * you're staring at them.
[]
> Btw., another possible way to organize the GUIDs would be to ignore checkpatch (we
> should ignore checkpatch when it's wrong)
Completely agree. checkpatch is brainless.
> and go for a nice table format:
>
> #define NULL_GUID EFI_GUID(0x00000000, 0x0000, 0x0000, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00)
Much nicer.
There are a few more files that use EFI_GUID.
It'd be good to standardize.
$ git grep --name-only -w EFI_GUID
arch/ia64/include/asm/sal.h
arch/ia64/kernel/esi.c
arch/x86/platform/efi/quirks.c
block/partitions/efi.h
drivers/infiniband/hw/hfi1/efivar.c
drivers/scsi/isci/probe_roms.h
include/linux/efi.h
Maybe a checkpatch line-length exclusion:
---
scripts/checkpatch.pl | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index 4904ced..cc787e6 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -2764,6 +2764,10 @@ sub process {
$line =~ /^\+\s*#\s*define\s+\w+\s+$String$/) {
$msg_type = "";
+ # EFI_GUID is another special case
+ } elsif ($line =~ /^\+.*\bEFI_GUID\s*\(/) {
+ $msg_type = "";
+
# Otherwise set the alternate message types
# a comment starts before $max_line_length
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 2/7] efi: Document #define FOO_PROTOCOL_GUID layout Matt Fleming <matt@codeblueprint.co.uk> - 2016-06-25 09:30 +0200
Re: [PATCH 2/7] efi: Document #define FOO_PROTOCOL_GUID layout Ingo Molnar <mingo@kernel.org> - 2016-06-27 12:50 +0200
Re: [PATCH 2/7] efi: Document #define FOO_PROTOCOL_GUID layout Joe Perches <joe@perches.com> - 2016-06-27 13:20 +0200
Re: [PATCH 2/7] efi: Document #define FOO_PROTOCOL_GUID layout Matt Fleming <matt@codeblueprint.co.uk> - 2016-07-04 15:20 +0200
[tip:efi/core] efi: Reorganize the GUID table to make it easier to read tip-bot for Ingo Molnar <tipbot@zytor.com> - 2016-07-08 15:30 +0200
[tip:efi/core] efi: Document #define FOO_PROTOCOL_GUID layout tip-bot for Peter Jones <tipbot@zytor.com> - 2016-06-27 15:10 +0200
csiph-web