Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1425852
| From | Vivien Didelot <vivien.didelot@savoirfairelinux.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 net-next v3 13/14] net: dsa: mv88e6xxx: add addressing mode to info |
| Date | 2016-06-18 23:20 +0200 |
| Message-ID | <rLvON-113-7@gated-at.bofh.it> (permalink) |
| References | <rLbZM-54e-5@gated-at.bofh.it> <rLbZM-54e-3@gated-at.bofh.it> <rLvc5-xN-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Andrew,
Andrew Lunn <andrew@lunn.ch> writes:
>> +struct mv88e6xxx_smi_ops {
>> + int (*read)(struct mii_bus *bus, int sw_addr,
>> + int addr, int reg, u16 *val);
>> + int (*write)(struct mii_bus *bus, int sw_addr,
>> + int addr, int reg, u16 val);
>> +};
>
> Hi Vivien
>
> I still think this API should be based on ps.
>
> With the way you have restructured probe, this now also works, there
> is no longer a read without PS in order to get the device ID.
>
> Also, think about the case of reading/writing registers via Ethernet
> frames. Such functions would need ps, bus and sw_addr is not useful.
Yes, I do RMU in mind, that was one motivation behind isolating
SMI-specific pieces of code.
I considered mv88e6xxx_smi_ops private to the SMI (MDIO) access, needing
an additional abstraction for regs access operations.
But I can indeed rename mv88e6xxx_smi_ops to mv88e6xxx_ops and make them
use a ps before one day, implementing an optional ps->rmu_ops.
Thanks,
Vivien
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v3 net-next v3 13/14] net: dsa: mv88e6xxx: add addressing mode to info Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2016-06-18 02:10 +0200
Re: [PATCH v3 net-next v3 13/14] net: dsa: mv88e6xxx: add addressing mode to info Andrew Lunn <andrew@lunn.ch> - 2016-06-18 22:40 +0200
Re: [PATCH v3 net-next v3 13/14] net: dsa: mv88e6xxx: add addressing mode to info Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2016-06-18 23:20 +0200
csiph-web