Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1420707
| From | "George Spelvin" <linux@sciencehorizons.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [patch 11/20] hlist: Add hlist_is_last_node() helper |
| Date | 2016-06-13 12:50 +0200 |
| Message-ID | <rJxBn-56h-11@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
Shouldn't this function be called hlist_is_only_node()? hlist_is_last_node would be simply !n->next, as "last" doesn't imply the lack of others. I understand how the name might make sense in the context of removing entries from the list, but in other contexts, it's confusing.
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [patch 11/20] hlist: Add hlist_is_last_node() helper "George Spelvin" <linux@sciencehorizons.net> - 2016-06-13 12:50 +0200
csiph-web