Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1411388

Re: [RFC PATCH 0/2] scpi: Add SCPI framework to handle vendors variants

From Kevin Hilman <khilman@baylibre.com>
Newsgroups linux.kernel
Subject Re: [RFC PATCH 0/2] scpi: Add SCPI framework to handle vendors variants
Date 2016-06-01 18:40 +0200
Message-ID <rFhlx-2kH-67@gated-at.bofh.it> (permalink)
References <rCZVM-4Fq-13@gated-at.bofh.it> <rD6kx-dV-1@gated-at.bofh.it> <rDl9U-XC-7@gated-at.bofh.it> <rEqTU-1KK-11@gated-at.bofh.it> <rFbpM-788-27@gated-at.bofh.it>
Organization BayLibre

Show all headers | View raw


[ + Heiko, who may know about the Rockchip implementation ]

Sudeep Holla <sudeep.holla@arm.com> writes:

> On 30/05/16 09:30, Neil Armstrong wrote:
>> On 05/27/2016 10:17 AM, Neil Armstrong wrote:
>
> [..]
>
>>
>> While looking for other ARMv8 based platform, I found that the RK3368
>> platform has the same SCPI implementation as Amlogic.
>>
>> They extended it with DDR, system and thermal commands.
>>
>> Look at :
>> https://github.com/geekboxzone/mmallow_kernel/blob/geekbox/drivers/mailbox/scpi_cmd.h
>>
>>https://github.com/geekboxzone/mmallow_kernel/blob/geekbox/drivers/mailbox/scpi_protocol.c
>>
>
>
>> So the SCPI must have a framework to allow different protocol
>> versions, and must allow command extension. Grouping Rockchip and
>> Amlogic should be done, thus needing a generic name like vendor_scpi
>> or with a version.
>>
>
> Makes sense. I understand the need to reuse and I need a bit of time to
> have a look at the code(both Amlogic one's you have pointed out and the
> Rockchip one) in detail to see what's the best way to proceed. I will
> have a look at this later this week and get back to you.
>
>> Sudeep, could you somehow find out which version of the protocol
>> AmLogic and Rockchip based their SCPI development ?
>>
>
> Yes I tried checking with Rockchip but didn't get a response. But my
> guess is that it was some preliminary unpublished version of SCPI
> unfortunately :(

And if one partner did that, probably everyone else did as well, but
this being the ARM universe, they all did it slightly differently. :(

We know from experience, that this happens all the time in the absence
of a clear standard, so this framework will need to be extended to be
useful.

Thanks,

Kevin

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [RFC PATCH 0/2] scpi: Add SCPI framework to handle vendors  variants Sudeep Holla <sudeep.holla@arm.com> - 2016-06-01 12:20 +0200
  Re: [RFC PATCH 0/2] scpi: Add SCPI framework to handle vendors variants Kevin Hilman <khilman@baylibre.com> - 2016-06-01 18:40 +0200
    Re: [RFC PATCH 0/2] scpi: Add SCPI framework to handle vendors  variants Sudeep Holla <sudeep.holla@arm.com> - 2016-06-01 18:40 +0200
    Re: [RFC PATCH 0/2] scpi: Add SCPI framework to handle vendors variants Heiko Stübner <heiko@sntech.de> - 2016-06-01 20:50 +0200

csiph-web