Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1349668

Re: [PATCH v2 3/4] resource: Add device-managed insert/remove_resource()

From Toshi Kani <toshi.kani@hpe.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2 3/4] resource: Add device-managed insert/remove_resource()
Date 2016-03-04 00:00 +0100
Message-ID <r8KnU-5IL-9@gated-at.bofh.it> (permalink)
References <r8mYj-5A6-11@gated-at.bofh.it> <r8mYl-5A6-53@gated-at.bofh.it> <r8Kee-5DY-19@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, 2016-03-03 at 14:45 -0800, Dan Williams wrote:
> On Wed, Mar 2, 2016 at 2:50 PM, Toshi Kani <toshi.kani@hpe.com> wrote:
 :
> > 
> > diff --git a/kernel/resource.c b/kernel/resource.c
> > index effb6ee..b1a3394 100644
> > --- a/kernel/resource.c
> > +++ b/kernel/resource.c
> > @@ -1449,6 +1449,75 @@ void __devm_release_region(struct device *dev,
> > struct resource *parent,
> >  EXPORT_SYMBOL(__devm_release_region);
> > 
> >  /*
> > + * Remove function for devm_insert_resource() and
> > devm_remove_resource().
> > + */
> > +static void devm_resource_remove(struct device *dev, void *ptr)
> > +{
> > +       struct resource **r = ptr;
> > +
> > +       remove_resource(*r);
> > +}
> > +
> 
> Maybe call this __devm_remove_resource?  I think this makes it clearer
> that it is a private helper function.  I was initially confused about
> the difference between devm_resource_remove and devm_remove_resource.

Will do.  I followed the naming convention of devm_resource_release() in
the same file, but I agree that this is confusing.

Thanks,
-Toshi

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 0/4] Support persistent memory as reserved type in e820/EFI Toshi Kani <toshi.kani@hpe.com> - 2016-03-02 23:00 +0100
  [PATCH v2 4/4] ACPI: Change NFIT driver to insert new resource Toshi Kani <toshi.kani@hpe.com> - 2016-03-02 23:00 +0100
    Re: [PATCH v2 4/4] ACPI: Change NFIT driver to insert new resource Dan Williams <dan.j.williams@intel.com> - 2016-03-03 23:50 +0100
      Re: [PATCH v2 4/4] ACPI: Change NFIT driver to insert new resource Toshi Kani <toshi.kani@hpe.com> - 2016-03-04 00:20 +0100
  [PATCH v2 3/4] resource: Add device-managed insert/remove_resource() Toshi Kani <toshi.kani@hpe.com> - 2016-03-02 23:00 +0100
    Re: [PATCH v2 3/4] resource: Add device-managed insert/remove_resource() Dan Williams <dan.j.williams@intel.com> - 2016-03-03 23:50 +0100
      Re: [PATCH v2 3/4] resource: Add device-managed  insert/remove_resource() Toshi Kani <toshi.kani@hpe.com> - 2016-03-04 00:00 +0100
  [PATCH v2 1/4] resource: Change __request_region to inherit from immediate parent Toshi Kani <toshi.kani@hpe.com> - 2016-03-02 23:00 +0100
  [PATCH v2 2/4] resource: Add remove_resource interface Toshi Kani <toshi.kani@hpe.com> - 2016-03-02 23:00 +0100

csiph-web